xfs
[Top] [All Lists]

Re: [PATCH] streamline init/exit path

To: Niv Sardi <xaiki@xxxxxxx>
Subject: Re: [PATCH] streamline init/exit path
From: Christoph Hellwig <hch@xxxxxx>
Date: Wed, 21 May 2008 08:01:03 +0200
Cc: Christoph Hellwig <hch@xxxxxx>, xfs@xxxxxxxxxxx
In-reply-to: <nccprrg32vr.fsf@xxxxxxx>
References: <20080518130511.GA28501@xxxxxx> <nccprrg32vr.fsf@xxxxxxx>
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: Mutt/1.3.28i
On Wed, May 21, 2008 at 10:41:12AM +1000, Niv Sardi wrote:
> Looks good, appart from the fact that I don't see the point of merging
> xfs_{init,destroy}_zones into xfs_{init,exit}, appart from clobbering it
> and making it less readeable.
> 
> could be:
> error = xfs_init_zones();
> if (error)
>       goto out;
> 
> and all the other error cases will end with
> xfs_destroy_zones();
> 
> That would look much more like the rest of the calls in these functions.

I don't really see the point for splitting this up, it's not like it
makes the initialization much simpler.  But hey, if that's the only
objection I can changed it.

At least someone is looking at my xfs patches :)


<Prev in Thread] Current Thread [Next in Thread>