xfs
[Top] [All Lists]

Repairing a possibly incomplete xfs_growfs command?

To: <xfs@xxxxxxxxxxx>
Subject: Repairing a possibly incomplete xfs_growfs command?
From: "Mark Magpayo" <mmagpayo@xxxxxxxxxxxxx>
Date: Wed, 16 Jan 2008 15:19:19 -0800
Sender: xfs-bounce@xxxxxxxxxxx
Thread-index: AchYl2UPy/3V5aeGTG6WxLQ5nlhTOA==
Thread-topic: Repairing a possibly incomplete xfs_growfs command?
Hi,

So I have run across a strange situation which I hope there are some
gurus out there to help.

The original setup was a logical volume of 8.9TB.  I extended the volume
to 17.7TB and attempted to run xfs_growfs.  I am not sure whether the
command actually finished, as after I ran the command, the metadata was
displayed, but there was no nothing that stated the the number of data
blocks had changed.  I was just returned to the prompt, so I'm not sure
whether the command completed or not..

I was unable write to the logical volume I had just created.  I tried to
remount it, but I kept getting an error saying the superblock could not
be read.  I tried running an xfs_repair on the filesystem, and get the
following:

Phase 1 - find and verify superblock...
superblock read failed, offset 19504058859520, size 2048, ag 64, rval 0

fatal error -- Invalid argument


I am not very experienced with xfs (I was following commands in some
documentaion), and I was recommended to post to this mailing list.  If
anyone could provide some help, it would be greatly appreciate.  Also,
if there is any information I can provide to help, I will gladly provide
it.  Thanks in advance!

Sincerely,

Mark



<Prev in Thread] Current Thread [Next in Thread>