xfs
[Top] [All Lists]

Re: 7Tb XFS partition lost on reboot

To: Eric Sandeen <sandeen@xxxxxxxxxxx>
Subject: Re: 7Tb XFS partition lost on reboot
From: Amandine AUPETIT <amandine@xxxxxxxxxxx>
Date: Thu, 08 Nov 2007 15:59:34 +0100
Cc: Joshua Baker-LePain <jlb17@xxxxxxxx>, xfs@xxxxxxxxxxx
In-reply-to: <4733201C.9060802@xxxxxxxxxxx>
References: <473072FD.4070104@xxxxxxxxxxx> <alpine.LRH.0.9999.0711061144540.17301@xxxxxxxxxxxxxxxxxxxxx> <4730B98C.5090008@xxxxxxxxxxx> <47330B8E.5010008@xxxxxxxxxxx> <4733201C.9060802@xxxxxxxxxxx>
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: Thunderbird 2.0.0.6 (X11/20071022)
Ok, sorry for the mix-up.
You were right, the problem was about the partition table.
Actually, even if it was a gpt partition table, it was corrupted. I seems to be a ubuntu parted problem. I had to rebuild pared from the sources and when I ran it, it said :

# ./parted
GNU Parted 1.8.8
Using /dev/cciss/c1d0
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print print Warning: /dev/cciss/c1d0 contains GPT signatures, indicating that it has a GPT
table.  However, it does not have a valid fake msdos partition table, as it
should.  Perhaps it was corrupted -- possibly by a program that doesn't
understand GPT partition tables. Or perhaps you deleted the GPT table, and are
now using an msdos partition table.  Is this a GPT partition table?
Yes/No? yes yes
Model: Compaq Smart Array (cpqarray)
Disk /dev/cciss/c1d0: 7501GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system  Name     Flags
1 17.4kB 7501GB 7501GB xfs primary


So I deleted the existing partition and recreated a new one. I found back all my data on this new partition, and on reboot there is no problem anymore.

Thanks a lot for your help ! :)

Amandine


Eric Sandeen a écrit :
Amandine AUPETIT wrote:
Hi,
Thanks for the advice !
I checked the label with xfs_admin -l :
# xfs_admin -l /dev/cciss/c1d0p1
label = ""

I tried to blank it in case there is something invisible :
# xfs_admin -L -- /dev/cciss/c1d0p1
writing all SBs
new label = ""

But it seems to be the same. :(

No, not the filesystem label, the disklabel, otherwise known as the
partition table - dos vs. gpt.  This is something you set with parted or
fdisk, not xfs_admin.

-Eric


<Prev in Thread] Current Thread [Next in Thread>