xfs
[Top] [All Lists]

Re: [fuse-devel] [PATCH 00/25] move handling of setuid/gid bits from VFS

To: Jan Engelhardt <jengelh@xxxxxxxxxxxxxxx>
Subject: Re: [fuse-devel] [PATCH 00/25] move handling of setuid/gid bits from VFS into individual setattr functions (RESEND)
From: Jeff Layton <jlayton@xxxxxxxxxx>
Date: Thu, 9 Aug 2007 07:55:02 -0400
Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>, codalist@xxxxxxxxxxxxxxxxxxxxxxxx, cluster-devel@xxxxxxxxxx, jfs-discussion@xxxxxxxxxxxxxxxxxxxxx, mikulas@xxxxxxxxxxxxxxxxxxxxxxxx, reiserfs-devel@xxxxxxxxxxxxxxx, zippel@xxxxxxxxxxxxxx, xfs@xxxxxxxxxxx, linux-kernel@xxxxxxxxxxxxxxx, wli@xxxxxxxxxxxxxx, joel.becker@xxxxxxxxxx, dhowells@xxxxxxxxxx, fuse-devel@xxxxxxxxxxxxxxxxxxxxx, jffs-dev@xxxxxxxx, user-mode-linux-user@xxxxxxxxxxxxxxxxxxxxx, linux-fsdevel@xxxxxxxxxxxxxxx, v9fs-developer@xxxxxxxxxxxxxxxxxxxxx, linux-ext4@xxxxxxxxxxxxxxx, linux-cifs-client@xxxxxxxxxxxxxxx, ocfs2-devel@xxxxxxxxxxxxxx, bfennema@xxxxxxxxxxxxxxxxxxxxxx
In-reply-to: <Pine.LNX.4.64.0708082204210.10387@xxxxxxxxxxxxxxxxxxxxxxxxx>
References: <200708061354.l76Ds3mU002255@xxxxxxxxxxxxxxxxxxxx> <20070807171501.e31c4a97.akpm@xxxxxxxxxxxxxxxxxxxx> <20070808085435.722f2b10.jlayton@xxxxxxxxxx> <20070808094853.8c27450c.akpm@xxxxxxxxxxxxxxxxxxxx> <Pine.LNX.4.64.0708082204210.10387@xxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xfs-bounce@xxxxxxxxxxx
On Wed, 8 Aug 2007 22:05:13 +0200 (CEST)
Jan Engelhardt <jengelh@xxxxxxxxxxxxxxx> wrote:

> 
> On Aug 8 2007 09:48, Andrew Morton wrote:
> >> > On Mon, 6 Aug 2007 09:54:03 -0400
> >> > Jeff Layton <jlayton@xxxxxxxxxx> wrote:
> >> > 
> >> > Is there any way in which we can prevent these problems?  Say
> >> > 
> >> > - rename something so that unconverted filesystems will reliably fail to
> >> >   compile?
> >> > 
> >> 
> >> I suppose we could rename the .setattr inode operation to something
> >> else, but then we'll be stuck with it for at least a while. That seems
> >> sort of kludgey too...
> >
> >Sure.  We're changing the required behaviour of .setattr.  Changing its
> >name is a fine and reasonably reliable way to communicate that fact.
> 
> Maybe ->chattr/->chgattr?
> 
> 

That seems like a good replacement name. :-)

Now that I think on this further though, maybe Trond's suggestion to
change how the return code works is the best one. That would
(hopefully) catch this problem at runtime, so if someone is using a
precompiled but unconverted module then that would be detected too.

--
Jeff Layton <jlayton@xxxxxxxxxx>


<Prev in Thread] Current Thread [Next in Thread>