[Top] [All Lists]

Re: 2.6.22-rc3 hibernate(?) fails totally - regression (xfs on raid6)

To: Tejun Heo <htejun@xxxxxxxxx>
Subject: Re: 2.6.22-rc3 hibernate(?) fails totally - regression (xfs on raid6)
From: David Greaves <david@xxxxxxxxxxxx>
Date: Thu, 07 Jun 2007 11:30:05 +0100
Cc: Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx>, "Rafael J. Wysocki" <rjw@xxxxxxx>, xfs@xxxxxxxxxxx, "'linux-kernel@xxxxxxxxxxxxxxx'" <linux-kernel@xxxxxxxxxxxxxxx>, linux-pm <linux-pm@xxxxxxxxxxxxxx>, Neil Brown <neilb@xxxxxxx>
In-reply-to: <46679D56.7040001@gmail.com>
References: <46608E3F.4060201@dgreaves.com> <200706012342.45657.rjw@sisk.pl> <46609FAD.7010203@dgreaves.com> <200706020122.49989.rjw@sisk.pl> <4661EFBB.5010406@dgreaves.com> <alpine.LFD.0.98.0706021538360.23741@woody.linux-foundation.org> <4662D852.4000005@dgreaves.com> <46667160.80905@gmail.com> <46668EE0.2030509@dgreaves.com> <46679D56.7040001@gmail.com>
Sender: xfs-bounce@xxxxxxxxxxx
User-agent: Mozilla-Thunderbird (X11/20070601)
Tejun Heo wrote:

David Greaves wrote:
Just to be clear. This problem is where my system won't resume after s2d
unless I umount my xfs over raid6 filesystem.

This is really weird. I don't see how xfs mount can affect this at all.
It does :)

How hard does the machine freeze?  Can you use sysrq?  If so, please
dump sysrq-t.
I suspect there is a problem writing to the consoles...

I recompiled (rc4+patch) with sysrq support, suspended, resumed and tried sysrq-t but got no output.

I *can* change VTs and see the various login prompts, bitmap messages and the console messages. Caps/Num lock lights work.

Fearing incompetence I tried sysrq-s sysrq-u sysrq-b and got a reboot so sysrq is OK.

Any suggestions on how to see more? Or what to try next?

Any other kernel debug options to set?

PS Back in a couple of hours...

<Prev in Thread] Current Thread [Next in Thread>