xfs
[Top] [All Lists]

Re: New CentOS4/RHEL4-compatible xfs module rpms

To: geir.myrestrand@xxxxxxxxxxxxxx
Subject: Re: New CentOS4/RHEL4-compatible xfs module rpms
From: Nathan Scott <nscott@xxxxxxxxxx>
Date: Fri, 08 Dec 2006 08:11:46 +1100
Cc: xfs@xxxxxxxxxxx, Eric Sandeen <sandeen@xxxxxxxxxxx>
In-reply-to: <45787ED4.5070801@xxxxxxxxxxxxxx>
Organization: Aconex
References: <4560AB84.9060200@xxxxxxxxxxx> <45784E71.4080605@xxxxxxxxxxxxxx> <457854CB.5030507@xxxxxxxxxxx> <45787ED4.5070801@xxxxxxxxxxxxxx>
Reply-to: nscott@xxxxxxxxxx
Sender: xfs-bounce@xxxxxxxxxxx
On Thu, 2006-12-07 at 15:51 -0500, Geir A. Myrestrand wrote:
> Eric Sandeen wrote:
> > Geir A. Myrestrand wrote:
> > 
> >> However, I run into issues with xfs_freeze as it often locks up when I 
> >> try to freeze a file system where there is I/O activity. Sometimes it 
> >> happen on the first xfs_freeze invocation to freeze the file system, 
> >> other times I have to unfreeze and then it happens on the second time I 
> >> freeze. xfs_freeze never returns when this happens.
> >>
> > 
> > Did you have this problem on the previous version?
> 
> I just tested with the old version, and I run into the same issue.
> 

Does it happen with mainline (current) kernels?  This is ringing some
distant bells, something to do with an atomic_inc being in the wrong
spot in [_]xfs_trans_alloc ... or maybe a wrong call to xfs_trans_alloc
instead of the '_' prefixed version - details are murky now though.  I
do remember fixing ... something in here, a few months back, that fix
may not be in Eric's codebase yet.

cheers.

-- 
Nathan


<Prev in Thread] Current Thread [Next in Thread>