xfs
[Top] [All Lists]

Re: vmsplice can't work well

To: "Jeffrey E. Hundstad" <jeffrey.hundstad@xxxxxxxx>
Subject: Re: vmsplice can't work well
From: Jens Axboe <axboe@xxxxxxxxx>
Date: Thu, 31 Aug 2006 11:24:41 +0200
Cc: xfs@xxxxxxxxxxx, nathans@xxxxxxx
In-reply-to: <44F5D3C6.1010108@xxxxxxxx>
References: <44F4440F.1090300@xxxxxxxxx> <20060829140542.GN12257@xxxxxxxxx> <44F5CC08.8010205@xxxxxxxx> <20060830174815.GF7331@xxxxxxxxx> <44F5D3C6.1010108@xxxxxxxx>
Sender: xfs-bounce@xxxxxxxxxxx
XFS list,

On Wed, Aug 30 2006, Jeffrey E. Hundstad wrote:
> Jens Axboe wrote:
> >On Wed, Aug 30 2006, Jeffrey E. Hundstad wrote:
> >  
> >>I tried your splie-git...tar.gz file and tried the splice-cp.  It 
> >>produced files that are the right length... but the files only contain 
> >>nulls.  Here's the straces:
> >>    
> >
> >Works for me as well. Could be an fs issue, how large was the README and
> >what filesystem did you use?
> >
> >  
> The file was 1130 bytes (it was the README in that directory.)  The 
> filesystem is XFS.
> 

I can reproduce this quite easily, doing:

nelson:~ # splice-cp sda.blktrace.0 foo

nelson:~ # md5sum sda.blktrace.0 foo
4754070ae77091468c830ea23b125d68  sda.blktrace.0
efdc7b9d00692fdfe91a691277209267  foo

'foo' contains only zeroes. Doing the same on ext3 yields the correct
results, foo contains the right data. I'm testing on
2.16.18-rc5-current, Jeffrey used 2.6.17.x latest.

-- 
Jens Axboe


<Prev in Thread] Current Thread [Next in Thread>