xfs
[Top] [All Lists]

Re: Problems With 2.4 XFS-NFS CVS Tree/Linux 2.6.15.1 Client

To: Jon Lewis <jlewis@xxxxxxxxx>
Subject: Re: Problems With 2.4 XFS-NFS CVS Tree/Linux 2.6.15.1 Client
From: "Sean P. Elble" <elbles@xxxxxxxxxx>
Date: Tue, 31 Jan 2006 23:01:53 -0500 (EST)
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <Pine.LNX.4.61.0601312248210.1877@xxxxxxxxxxxxxxxx>
References: <Pine.LNX.4.64.0601231054140.11064@xxxxxxxxxxxxxxx> <Pine.LNX.4.61.0601312248210.1877@xxxxxxxxxxxxxxxx>
Sender: linux-xfs-bounce@xxxxxxxxxxx
Jon,

Thanks for a reply. Doing a Google search for the problem caused your name to pop up, but that was it as far as related items were concerned. I was hoping it was a problem that had been fixed since then, but apparently not. All updates seem to be to the 2.6 tree, with the 2.4 tree basically in a state of neglect as far as SGI is concerned.

As far as solving the problem, I *tried* to upgrade the 2.4 system to a 2.6 kernel, but that didn't go as planned, with the system going failing sometime during reboot, and causing file system problems. Since I was stupid and did this on a system that is 600 miles away physically, it'll be that way until I go home next time. (The server was actually the main file server at my house, and being a college student, it's hard to take a 1200 mile roundtrip in a weekend. :-)) I do appreciate the reply: it's good to know someone else is running into the same problems.

-Sean Elble

On Tue, 31 Jan 2006, Jon Lewis wrote:

On Mon, 23 Jan 2006, Sean P. Elble wrote:

I have 2 servers setup, one is strictly a file server with a 100 GB drive formatted with XFS (with the operating system residing on another drive formatted as ext2), exporting shares via NFS from both the XFS partition and the ext2 partitions. The ext2 partitions export fine, and can be read fine on the "client" (really, the server that does most of the work, which is running the 2.6.15.1 kernel), but there are major issues with the XFS partition. It seems to export fine, and I can run an ls at the top of the NFS mount, but nothing else works, and I mean nothing else. What follows is the output of the mount, pwd, and ls commands on the client:

I didn't see any reply to this, but just wanted to let you know I ran into exactly the same problem (and posted here about it) not too long ago (couple months?). Has anyone figured this out yet?

----------------------------------------------------------------------
Jon Lewis                   |  I route
Senior Network Engineer     |  therefore you are
Atlantic Net                |
_________ http://www.lewis.org/~jlewis/pgp for PGP public key_________



<Prev in Thread] Current Thread [Next in Thread>