xfs
[Top] [All Lists]

getfacl crashes

To: linux-xfs@xxxxxxxxxxx
Subject: getfacl crashes
From: Charles Weber <weberc@xxxxxxxxxxxxxxxxxxxxxxxx>
Date: Mon, 20 Dec 2004 16:18:05 -0500
Sender: linux-xfs-bounce@xxxxxxxxxxx
I have some older samba with acl servers to retire. they are
redhat 7.3
2.4.21-xfs kernel
xfsprogs-2.5.6-0
acl-2.2.15-0

My new server is
FC2
2.6.8-1.521smp x86_64
xfsprogs-2.6.25-1
acl-2.2.27-1

I have gotten good service except some the filesystems have become
confused as to file size, that is a 400 GB partition may have some
directories that think they contain 600 GB. The servers have been used
for PC and Mac samba, so I have some funny (such as :: or " or chinese
characters) names. I also have to change uid to sid samba mapping after
the copy.

My test strategy is to smbmount onto the new server, star the files
over, getfacl -R olddir >file.lst and then replay the acl file to apply
acl rights on the new file share. Then I fix all the ugly file name
errors and move on. This takes care of acl and uid properly when testing
on 30 GB directories.

When I tried it with a 250GB samba share, I ran into the problem of
getfacl not finishing the logging of acls and the not so serious problem
of setfacl not finishing when it ran into some illegal file names.

Comments, suggestions or xfsprog suggested versions are welcome.
I am reluctant to xfsrepair the partitions as I dont want to risk losing
any data.

Chuck


<Prev in Thread] Current Thread [Next in Thread>