xfs
[Top] [All Lists]

Oops when running xfs_fsr

To: "'linux-xfs@xxxxxxxxxxx'" <linux-xfs@xxxxxxxxxxx>
Subject: Oops when running xfs_fsr
From: Joe Eiler <jeiler@xxxxxxxxxxx>
Date: Tue, 31 Aug 2004 23:06:37 -0500
Sender: linux-xfs-bounce@xxxxxxxxxxx
I am getting an Oops when running xfs_fsr.  The only way I can get it to
disappear is to turn on debugging in the kernel ;-)  From my limited stack
tracing abilities it doesn't look like and xfs problem but I can't reproduce
it anyother way than with xfs_fsr.

I have reliably reproduced the problem on 3 different machines running
2.6.7, 2.6.8.1 (from kernel.org)  Most of the rest of the system is fedora
core2 rpms.
I already tried the latest xfs-cmds from cvs. (xfs is latest from cvs also)

When I get the Oops, the system is locked up and nothing gets saved to the
logs.(So I am taking the Oops off the screen by hand ;-( Oh, kernel is
tainted due to imq module but I tried it once without imq loaded.

Some config info.
local ide harddrive is formatted with reiserfs
my data volume is on a 12drive 3ware controller(lvm on two 6 drive raid 10s)
and is formated with xfs with an external log.

#xfs_fsr /base/d0
/base/d0 start inode = 0
Unable to handle kernel NULL pointer dereference at virtual address 00000005
printing eip:
c01c0eab
*pde = 00000000
Oops: 0002 [#1]
SMP
Modules linked in: xfs_quota xfs nfsd exportfs lockd raw imq sg sunrpc e1000
uhci_hcd usbcore thermal processor fan button dm_mod 3w_xxxx sd_mod scsi_mod
CPU: 0
EIP: 0060[<c01c0eab>] Tainted: P
EFLAGS: 00010282 (2.6.8.1)
EIP is at reiserfs_add_ordered_list+0x4b/0xd0
eax: f41b9088 ebx: f41b9080 ecx: f41b908c edx: 00000001
esi: e7a19590 edi: f8b4b000 ebp: f7fe7e00 esp: f49ffdb4
ds: 007b      es: 007b      ss: 0068
Process hydra (pid:1242, threadinfo=f499e000 task=f51a8bf0)
Stack: 00000001 e7a19590 00001000 c01aa96c f35a8750 e7a19590 00000000
00000001
       00000000 00000000 e7a19590 00001000 00000000 f77c7590 0000001f
f6a27660
       00000036 00000000 00000014 00000000 00000000 00000115 00000115
00000000
Call Trace: 
reiserfs_commit_page+0x18c/0x260
reiserfs_submit_file_region_for_write+0x7b/0x320
reiserfs_file_write+0x54b/0x7a0
do_no_page+0x6c/0x280
__vma_link+0x44/0x80
do_page_fault+0x18b/0x593
do_mmap_pgoff+0x3fa/0x710
vfs_write+0xb8/0x140
sys_write+0x51/0x80
sysenter_past_esp+0x52/0x71
code 89 4a 04 89 11 89 40 04 89 43 08 8b 87 b4 00 00 00 8d 53 08

The process will change frequently (this one is my custom app, but I have
seen it do with sed, sdt, kswapd, etc.)  It looks like more of the times the
apps are trying to write to the local disk(duh!)
The Call trace always takes one of two paths, the one in the above oops and
the other through reiserfs_get_block

Tomorrow, I'll try to move the console to a serial port so I can catch the
Oops directly.

If you got this far through my message, thanks for hanging in there,
Joe


<Prev in Thread] Current Thread [Next in Thread>
  • Oops when running xfs_fsr, Joe Eiler <=