xfs
[Top] [All Lists]

Corrupted Filesystem

To: linux-xfs@xxxxxxxxxxx
Subject: Corrupted Filesystem
From: "Tilo Lutz" <TiloLutz@xxxxxx>
Date: Mon, 21 Jun 2004 11:36:12 +0200 (MEST)
Sender: linux-xfs-bounce@xxxxxxxxxxx
Hi

I have the following setup:
/dev/hda4 contains a FAT32 filesystem containing a big
file crypto.loop (1024MB).
This file contains an encrypted filesystem with xfs.
I run losetup -e encryption /dev/loop0 /../file and
mount /dev/loop /mnt
to mount and use it.

Unfortunatly the FAT filesystem got corrupted and destroyed
crypto.loop. After running fsck.msdos I got a smaller crpyto.loop
with 512MB and to files fsck0000.rec and fsck0001.rec. Together
all files are 1024MB the ols size of crypto.loop.

I tried to put the files together so I can mount
or repair it with xfs_repait but xfs_repairs always
fails because it can't find a valid superblock.

I've decrypted all three files as saved them as part1 part2 and part3
The First Starts with "XFSB....." so I think the start is OK.
In part2 I can recognize some of my filecontent.

Here are some error-messages before I run fsck.msdos:
FAT: Filesystem panic (dev hda4)
fat_get_cluster: invalid cluster chain (i_pos 431368)
Zum anderen habe ich einen Fehler von losetup:
Buffer I/O error on device loop0, logical block 131791

Does anybody have an idea how I can put the files together to get
my data back?

I think content of part2 have to be put in part1. Can xfs_repair tell
me the first invalid block it find? This should be the place where I have to
put part2 in.

Regards, Tilo



Regards, Tilo


<Prev in Thread] Current Thread [Next in Thread>