xfs
[Top] [All Lists]

Re: [Evms-devel] XFS + evms + FS Corruption

To: Jord Tanner <jord@xxxxxxxxxxxxx>
Subject: Re: [Evms-devel] XFS + evms + FS Corruption
From: Jan De Landtsheer <jan@xxxxxxxxxxxx>
Date: Tue, 01 Jun 2004 09:27:41 +0200
Cc: evms-devel@xxxxxxxxxxxxxxxxxxxxx, hvisage@xxxxxxxxxxxxxx
In-reply-to: <40BB48A3.1050205@xxxxxxxxxxxxx>
References: <40BB48A3.1050205@xxxxxxxxxxxxx>
Sender: linux-xfs-bounce@xxxxxxxxxxx
On Mon, 2004-05-31 at 17:00, Jord Tanner wrote:
Yes I have exactly the same problems for the XFS thing...
I even is so that I hed to switch to ext3 for the time being, and the
problems to the looks of it, only occur on / mounts... strange enough.
XFS_WANT CORRUPTED_GOTO in line 866 of after some time, generating
massive FS corruption.
Attached the error.
They occur on AMD64,IA64,I386, all the same, as well on SATA, as on
SCSI, Raid-[015] straight MD-devices, Device-mapper, EVMS, so the
problem lies in XFS, I think, not in EVMS.

> This may or may not be related, however, I had trouble running XFS on 
> top of LVM2 on top of linux RAID0, running on gentoo 2.6.5 amd64. The 
> problems went away after switching to JFS. I was experiencing database 
> corruption, not system hangs. Someone said to me, somewhat off the cuff 
> "Sounds awfully stacky to me", and that spured me to try something other 
> than XFS. My take on the issue was that XFS + DM (lvm2) + RAID0 cause 
> some stack overflow, or something similar. Other file systems are not a 
> stack intensive as XFS, and thus don't have the problems. Since EVMS 
> also uses DM, I would expect similar problems as I had with LVM2.
> 
> This is pure conjecture on my part. All I know is switching from XFS to 
> JFS solved my problems. YMMV!
> 
> Jord Tanner
> Indpendent Gecko Consultants
> 
> 
> 
> >Hi there,
> >
> > A shot in the dark here: Any body else  have a similar setup to test
> >a problem I'm seeing? I consistently get hard hangs (no errors etc. on
> >console/logs/etc.) while transfering data via either NFS or rsync to a 
> >x86_64 running 2.6.5-gentoo XFS partition on a EVMS volume with a md0
> >storage object.
> >
> >The reiserfs partitions doesn't have any troubles (but those are not yet
> >md0, only straight EVMS partition type volumes), and neither did I have any
> >troubles with local reiserfs-> XFS transfers.
> >
> >Hendrik
> >/who doesn't yet got the whole evms lingua undercontrol
> >
> 
> 
> -------------------------------------------------------
> This SF.Net email is sponsored by: Oracle 10g
> Get certified on the hottest thing ever to hit the market... Oracle 10g. 
> Take an Oracle 10g class now, and we'll give you the exam FREE.
> http://ads.osdn.com/?ad_id=3149&alloc_id=8166&op=click
> _______________________________________________
> Evms-devel mailing list
> Evms-devel@xxxxxxxxxxxxxxxxxxxxx
> To subscribe/unsubscribe, please visit:
> https://lists.sourceforge.net/lists/listinfo/evms-devel

Attachment: XFS_WANT
Description: Text document

<Prev in Thread] Current Thread [Next in Thread>
  • Re: [Evms-devel] XFS + evms + FS Corruption, Jan De Landtsheer <=