[Top] [All Lists]

Re: BLKGETSIZE64, BLKBSZSET, BLKSSZGET definition in xfsprogs.

To: Jan Derfinak <ja@xxxxxxxxxxxx>
Subject: Re: BLKGETSIZE64, BLKBSZSET, BLKSSZGET definition in xfsprogs.
From: Nathan Scott <nathans@xxxxxxx>
Date: Thu, 9 Oct 2003 09:52:16 +1000
Cc: "Kevin P. Fleming" <kpfleming@xxxxxxxxxxxxxxxxxxxx>, linux-xfs@xxxxxxxxxxx
In-reply-to: <Pine.LNX.4.53.0310081227010.1331@xxxxxxxxxxxxxxxxxx>
References: <Pine.LNX.4.53.0310060739360.16790@xxxxxxxxxxxxxxxxxx> <20031006055957.GC1001@frodo> <Pine.LNX.4.53.0310071107220.1331@xxxxxxxxxxxxxxxxxx> <3F82C06A.1020808@xxxxxxxxxxxxxxxxxxxx> <Pine.LNX.4.53.0310071542510.1331@xxxxxxxxxxxxxxxxxx> <3F82CFFB.2000209@xxxxxxxxxxxxxxxxxxxx> <Pine.LNX.4.53.0310072003480.1331@xxxxxxxxxxxxxxxxxx> <3F8382D3.5050703@xxxxxxxxxxxxxxxxxxxx> <Pine.LNX.4.53.0310081227010.1331@xxxxxxxxxxxxxxxxxx>
Sender: linux-xfs-bounce@xxxxxxxxxxx
User-agent: Mutt/1.5.3i
On Wed, Oct 08, 2003 at 12:35:14PM +0200, Jan Derfinak wrote:
> On Tue, 7 Oct 2003, Kevin P. Fleming wrote:
> > Jan Derfinak wrote:
> >
> > > Is there any reason to stay with old definition and have different
> > > definition of these macros in kernel and in xfsprogs?
> > > Did I miss something?
> > >
> >
> > There is no particular reason to stay with the old definitions, but
> > there's no particular reason (or rush) to change them either. The two
> I disagree with you. The old definition isn't good and change in kernel is
> reasonable. Not syncing xfsprogs with kernel brings confusion to source code
> and in current status xfsprogs are not compilable with recent kernel.

If it doesn't compile, please send a patch (and the compile error).



<Prev in Thread] Current Thread [Next in Thread>