xfs
[Top] [All Lists]

Compile error on 2.6.0-test3

To: linux-xfs@xxxxxxxxxxx
Subject: Compile error on 2.6.0-test3
From: Jordi Mallach <jordi@xxxxxxxxxxxxxx>
Date: Thu, 21 Aug 2003 23:36:14 +0200
Sender: linux-xfs-bounce@xxxxxxxxxxx
User-agent: Mutt/1.5.4i
Hi,

I have searched the archive for this problem, but haven't found
anything related.

I have been trying to compile Linux 2.6.0-test3 without luck. The build
dies at:


  CC      fs/xfs/xfs_alloc.o
In file included from fs/xfs/xfs_alloc.c:42:
fs/xfs/xfs_sb.h:1:1: warning: null character(s) ignored
fs/xfs/xfs_sb.h:1:1: warning: no newline at end of file
In file included from fs/xfs/xfs_alloc.c:46:
fs/xfs/xfs_mount.h:286: syntax error before "xfs_sb_t"
fs/xfs/xfs_mount.h:286: warning: no semicolon at end of struct or union
fs/xfs/xfs_mount.h:387: syntax error before '}' token
fs/xfs/xfs_mount.h:387: warning: type defaults to `int' in declaration of 
`xfs_mount_t'
fs/xfs/xfs_mount.h:387: warning: data definition has no type or storage class
fs/xfs/xfs_mount.h:506: syntax error before '*' token
[... and more...]

I have tried -mm2 and -mm3, no changes, I also have tried going back to
gcc 3.2, same result.

This is a Debian sid box: gcc-3.3, glibc 2.3.2. 2.6.0-test2 compiled
just fine, it's the kernel I'm running right now.

Any clues?

Thanks,
Jordi
-- 
Jordi Mallach Pérez  --  Debian developer     http://www.debian.org/
jordi@xxxxxxxxxxxxxx     jordi@xxxxxxxxxx     http://www.sindominio.net/
GnuPG public key information available at http://oskuro.net/~jordi/

Attachment: pgpWiavXJ1IS9.pgp
Description: PGP signature

<Prev in Thread] Current Thread [Next in Thread>