xfs
[Top] [All Lists]

Re: hitting the BUG() in filemap.c:843 (in unlock_page())

To: linux-xfs <linux-xfs@xxxxxxxxxxx>
Subject: Re: hitting the BUG() in filemap.c:843 (in unlock_page())
From: Luben Tuikov <luben@xxxxxxxxxxxx>
Date: Wed, 16 Oct 2002 21:05:45 -0400
Organization: Splentec Ltd.
References: <Pine.LNX.4.44.0210160921400.16178-100000@xxxxxxxxxxxxx> <1034780582.15709.5.camel@xxxxxxxxxxxxxxxxxxxxxx>
Sender: linux-xfs-bounce@xxxxxxxxxxx
Eric Sandeen wrote:
> 
> Could you guys try this patch, it should detect some stack overflows, in
> case that's what you're hitting...  Meanwhile, perhaps we can set up a
> similar test here.
>

Tried it. Same bug.

Here's is our setup -- more detailed:

2.4.19 stock,

ftp://oss.sgi.com/projects/xfs/download/patches/2.4.19/xfs-2.4.19-all-i386.bz2
   from 2002-09-27, 4:22 UTC.

Using the LVM from the stock kernel. The lvm commands are the ones from
1.1-rc2 and you may see some not understood ioctls, but we've ignored them.

This is /etc/raidtab:
raiddev /dev/md0
        raid-level              5
        nr-raid-disks           4
        nr-spare-disks          0
        persistent-superblock   1
        parity-algorithm        left-symmetric
        chunk-size              64

        device                  /dev/sda
        raid-disk               0
        device                  /dev/sdb
        raid-disk               1
        device                  /dev/sdc
        raid-disk               2
        device                  /dev/sdd
        raid-disk               3
-------------------------------------------------------
This is the script to create the vg/lv device:
#!/bin/bash

. ./DEVICE_NAMES

DEVICE=/dev/md0

pvcreate -ffy $DEVICE

vgcreate $VG -s32M -p255 -l256 $DEVICE

lvcreate -L1G -n${LV} $VG
--------------------------------------------------------
This is the script to mount the device:
#!/bin/bash

. ./DEVICE_NAMES 

# FSPROG=mke2fs
# FSTYPE=ext2
FSPROG="mkfs.xfs -f"
FSTYPE=xfs

MOUNTP=/mnt/disk

echo Unmounting...
umount ${MOUNTP}
echo Sleeping for 2...
sleep 2

echo Doing work...

${FSPROG} /dev/${VG}/${LV}
echo "sleeping ..."
sleep 3
mount -t ${FSTYPE} -onoatime,nodiratime,usrquota,grpquota /dev/${VG}/${LV} 
${MOUNTP}
----------------------------------------------
And this is DEVICE_NAMES file:
# VG= the name of the vol group; LV= the name of the log. vol.
VG=vg0
LV=lv0
----------------------------------------------

The kernel has NO quota compiled in, only the one from xfs and
it has HIGHMEM enabled to 4 GB.

Try this set up, you should get the same bug and the same
stack trace.

In the mean time I'll the the latest CVS trunk, which is what you tried
I think.

-- 
Luben


<Prev in Thread] Current Thread [Next in Thread>