xfs
[Top] [All Lists]

Re: xfsrestore bus error

To: Matthew Rose <mat@xxxxxxxxxxx>
Subject: Re: xfsrestore bus error
From: Tim Shimmin <tes@xxxxxxx>
Date: Fri, 4 Oct 2002 13:27:05 +1000
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <20021003142456.GA1566@xxxxxxxxxxx>; from mat@xxxxxxxxxxx on Thu, Oct 03, 2002 at 03:24:56PM +0100
References: <20021003142456.GA1566@xxxxxxxxxxx>
Sender: linux-xfs-bounce@xxxxxxxxxxx
Hi Matthew,

On Thu, Oct 03, 2002 at 03:24:56PM +0100, Matthew Rose wrote:
> I have an xfs filesystem on an lvm volume on an i386 ide disk. xfsdump
> seems to happily work:
> 
> date=`date +%y-%m-%d`
> xfsdump -l 0 -p 30 -L home.full.$date -M home.full.$date - /home
> 
> I wanted to save the dumps to cd so I pipe the above dump into split:
> 
> | split --bytes=700m - home.0.$date.
> 
> then create iso9660 images and burn them.
> 
> When I restore, I copy the files then cat them into xfsrestore -
> <dest>
> 
> Should this work? 

Yes. I can't see why not.
I just tried it and it worked for me :)

> At the moment cat home.0.02-10-01.a* | xfsrestore -p
> 30 -J -v trace - /mnt/temp/ seems happy until it suddenly returns 135
> complaining of "bus error".
> 
> I can't find any mention of bus error in the xfsdump-2.0.1 source or
> cat.c. I don't know where the message is coming from.
> 
I would presume the "Bus error" is just the program
crashing out from a SIGBUS signal with some address access problem
such as an invalid alignment access.

> If there is something obviously wrong with my regime then what is it?
> Otherwise, where do you suggest I look next?
> 
Can you email the output from xfsrestore with -v 5.
You could also trying running xfsrestore in gdb and seeing
where it is dying.
(I'll post an SGI bug for it for the xfsdump person to look at)

> Here is the output from xfsrestore:
> 
> xfsrestore: using file dump (drive_simple) strategy
> xfsrestore: version 3.0 - Running single-threaded
> xfsrestore: searching media for dump
> xfsrestore: examining media file 0
> xfsrestore: file 0 in object 0 of stream 0
> xfsrestore: file 0 in stream, file 0 of dump 0 on object
> xfsrestore: dump description: 
> xfsrestore: hostname: homer
> xfsrestore: mount point: /home
> xfsrestore: volume: /dev/homerdata/home
> xfsrestore: session time: Tue Oct  1 06:52:02 2002
> xfsrestore: level: 0
> xfsrestore: session label: "home.full.02-10-01"
> xfsrestore: media label: "home.full.02-10-01"
> xfsrestore: file system id: d784a76e-45e9-4910-aa26-01e6b59d85d4
> xfsrestore: session id: d783a9f1-808b-49c8-ad36-0f58baa610e0
> xfsrestore: media id: 46e82ac2-817c-4415-b106-a9703ba0c2a7
> xfsrestore: searching media for directory dump
> xfsrestore: dump session label: "home.full.02-10-01"
> xfsrestore: dump session id: d783a9f1-808b-49c8-ad36-0f58baa610e0
> xfsrestore: stream 0, object 0, file 0
> xfsrestore: initializing directory attributes registry
> xfsrestore: initializing directory entry name registry
> xfsrestore: initializing directory hierarchy image
> Bus error
> 
> 
--Tim


<Prev in Thread] Current Thread [Next in Thread>