xfs
[Top] [All Lists]

[Bug 185] New: Mount by LABEL does not work on whole disks.

To: xfs-master@xxxxxxxxxxx
Subject: [Bug 185] New: Mount by LABEL does not work on whole disks.
From: bugzilla-daemon@xxxxxxxxxxx
Date: Fri, 18 Oct 2002 14:53:59 -0700
Sender: linux-xfs-bounce@xxxxxxxxxxx
http://oss.sgi.com/bugzilla/show_bug.cgi?id=185

           Summary: Mount by LABEL does not work on whole disks.
           Product: Linux XFS
           Version: 1.1.x
          Platform: IA32
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: Medium
         Component: XFS kernel code
        AssignedTo: xfs-master@xxxxxxxxxxx
        ReportedBy: austin@xxxxxxxxxxxxxxx


If this is a userspace bug, what version of the package are you using:

What kernel are you using: 2.4.19-aa1

Where did the XFS code come from?: Part of the -AA tree.

Description of Problem:
Mounting whole disks, rather than partitions, does not work by LABEL=


How Reproducible:

Easily reproduceable.


Steps to Reproduce:
1.  Using a whole scsi disk, mkfs.xfs on it, 
2.  Using xfs_admin -L somelabel /dev/sdN (where N is a-z)
3.  Add a LABEL=somelabel entry in /etc/fstab
4.  mount /somemountpoint

This will fail.

Actual Results:
Mount says the label does not exist.

Expected Results:
Should be able to mount whole disks by label.

Additional Information:
cat /proc/partitions sees the whole disks. Disks just don't have any partitions.



------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.


<Prev in Thread] Current Thread [Next in Thread>