xfs
[Top] [All Lists]

re: 2 freeze/snapshot questions

To: Greg Freemyer <freemyer@xxxxxxxxxxxxxxxxx>, <linux-xfs@xxxxxxxxxxx>
Subject: re: 2 freeze/snapshot questions
From: Greg Freemyer <freemyer@xxxxxxxxxxxxxxxxx>
Date: Fri, 16 Aug 2002 15:29:05 -0400
Organization: The NorcrossGroup
Sender: owner-linux-xfs@xxxxxxxxxxx
More info:

I went to another shell session and did a xfs_freeze -u /config and the initial 
lvcreate finished fine.

So that answers my second question.

Thanks
Greg
 >>  I'm testing snapshots under xfs for the first time.

 >>  I'm using LVM from the SuSE 8.0 release and a updated SuSE kernel that was
 >>  released at the end of July

 >>  I tried a simple
 >>  lvcreate --snapshot -L 25m --name config_snap /dev/VG1/config
 >>  lvscan
 >>  lvremove /dev/VG1/config_snap

 >>  and it worked fine.  (I only tried it once.)

 >>  I just tried
 >>  xfs_freeze -f /config
 >>  lvcreate --snapshot -L 25m --name config_snap /dev/VG1/config
 >>  xfs_freeze -u /config
 >>  lvremove /dev/VG1/config_snap

 >>  and the lvcreate command seems to be locked up.  Also, a lvscan is now
 >>  core dumping with a segmentation fault.

 >>  So I have 2 questions:

 >>  Should the above work?  And if not, what is the right way to do this?

 >>  How can I get the lvcreate to terminate?  I tried kill -9, but it had no
 >>  effect.

 >>  Thanks
 >>  Greg
 >>  =======
 >>  Greg Freemyer
 >>  Internet Engineer
 >>  Deployment and Integration Specialist
 >>  Compaq ASE - Tru64 v4, v5
 >>  Compaq Master ASE - SAN Architect
 >>  The Norcross Group
 >>  www.NorcrossGroup.com






Greg Freemyer
Internet Engineer
Deployment and Integration Specialist
Compaq ASE - Tru64 v4, v5
Compaq Master ASE - SAN Architect
The Norcross Group
www.NorcrossGroup.com


<Prev in Thread] Current Thread [Next in Thread>