xfs
[Top] [All Lists]

Re: WARNIG: NFS3-server broken in RH-7.3 XFS Installer

To: korn@xxxxxxxxxx
Subject: Re: WARNIG: NFS3-server broken in RH-7.3 XFS Installer
From: Simon Matter <simon.matter@xxxxxxxxxxxxxxxx>
Date: Wed, 10 Jul 2002 14:46:47 +0200
>received: from mobile.sauter-bc.com (unknown [10.1.6.21]) by basel1.sauter-bc.com (Postfix) with ESMTP id BCB5557306; Wed, 10 Jul 2002 14:46:47 +0200 (CEST)
Cc: linux-xfs <linux-xfs@xxxxxxxxxxx>
Organization: Sauter AG, Basel
References: <3D2C21DF.9080702@xxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Andreas Korn schrieb:
> 
> I had a newly install box with RH-7.3 and the XFS installer disk running
> as nfs-server (NFS3). The kernel was the precompiled kernel from the
> installer (2.4.18-4SGI_XFS_1.1). The disks had xfs filesystem. The nfs
> server would occasionally hang for some time (several minutes) and
> sometimes recover. During this time the kupdated process used all
> available CPU time and the nfsd processes had been put to sleep (or
> maybe deadlocked). Everything else was ok. After this I ran bonnie on
> some NFS mounts and I would hang shortly after all buffers on the server
> were used up. bonnie exited with an I/O error. The server showed the
> same behavior  but never recovered. I had hangs with lokally mounted
> nfs, too.
> After switching to kernel 2.4.19-rc1 with the appropriate xfs-patch all
> was well again. On another box with plain 2.4.18 + xfs-1.1 the problem
> also didn't occur. Only with the kernel from the installer.
> 

There is a new RedHat kernel in the errata with NFS fixes, maybe this
one would run okay. Unfortunately AFAIK nobody has XFS enabled it yet.

http://rhn.redhat.com/errata/RHBA-2002-110.html

Simon

> This is only intended as a warning for all who may want to use similar
> setup.
> 
> Andreas
> 
> --
> Do not meddle in the affairs of wizards,
> for they are subtle and quick to anger!



<Prev in Thread] Current Thread [Next in Thread>