xfs
[Top] [All Lists]

Re: xfs-filesystem is broken after rsync (log-info)

To: Dirk Munzinger <Dirk.Munzinger@xxxxxxxxxxxx>, linux-xfs@xxxxxxxxxxx
Subject: Re: xfs-filesystem is broken after rsync (log-info)
From: Seth Mos <knuffie@xxxxxxxxx>
Date: Wed, 31 Jul 2002 09:41:22 +0200
In-reply-to: <3D4779F9.70309@sem-gmbh.com>
References: <E17ZYZa-0002Nb-00@ADSL-Bergs.RZ.RWTH-Aachen.DE>
Sender: owner-linux-xfs@xxxxxxxxxxx
At 07:47 31-7-2002 +0200, you wrote:
Moin,

Ralf G. R. Bergs schrieb:
On Tue, 30 Jul 2002 16:34:28 +0200, Dirk Munzinger wrote:

By the way befor I switched the partition to xfs it was formated with reiserfs and there were no problems. The disk itself also seams to be ok.

Well, *seems* to be ok or *is* ok?!
I'm asking this since we also had a hell of problems when we tried to migrate our RAID to XFS. It turned out that it wasn't XFS' fault but that the XFS drive was bad... :-((

Good question ;-) At the moment it seems to be OK but I will check it again with an other fs later and let you know.

I have a number of XFS boxes and they all use rsync in one way or the other in 15,30 or 6 hour intervals and all goes well. I suspect broken hardware. It can sometimes be very subtle and only be caused by certain access patterns or drivers.


Can you try checking out a XFS CVS tree? I believe you said you were using the 1.1 release.
I have good results with the 2.4.19-rc3-xfs CVS tree on a number of different systems and it works really well. Can you check if this helps for you?


Cheers

--
Seth
It might just be your lucky day, if you only knew.


<Prev in Thread] Current Thread [Next in Thread>