[Top] [All Lists]

Re: XFS corruption!

To: Libor Vanek <libor@xxxxxxxx>, linux-xfs@xxxxxxxxxxx
Subject: Re: XFS corruption!
From: Seth Mos <knuffie@xxxxxxxxx>
Date: Thu, 27 Jun 2002 09:12:03 +0200
In-reply-to: <3D1AAB70.4060400@xxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
At 08:06 27-6-2002 +0200, Libor Vanek wrote:
we are selling Linux file servers and we wanted to use XFS. Our internal tests passed OK but when we installed first server at customer and migrated data an error occured (usually after copying 60-100 GB). In /var/log/messages we saw this messages:

One of the developers better comment on those messages.

We tried migrating 160 GB of data using "cp -a" (over NFS), scp and rsync from old server using RH7.0 (ext2) - all resulted in this. The system is running software RAID5 (10x60GB), 1 GHz Celeron, 128 MB RAM, standard RH7.3 with SGI XFS modified installation CD. When we rebooted system everything seems OK (nothing lost) but after copying few more MB the same error occurs. We have built up 2 VERY same machines from same system image and both behave the very same so I think that it's some software failure.

It sounds like it. Did you build this filesystem with any special mkfs options?
What IDE controllers are you using? Did you use the 2.4.18 kernel that came on the installer disk or is this a selfcompiled version or even a CVS checkout?

I have stress tested system with doing lot of "dd if=/dev/md0 of=/raid/tmp bs=10MB count=100" and recursive directories (about 50 levels deep) and nothing similar occured. Only when copying data over network from the old system.

Weird. I frequently have to copy large amounts of data over the network and it works fine so I suspect that something in your filesystem is not right and causing it to fail again as soon as you try to copy to it again.

Can you check/repair the filesystem and see if it appears again?

It might just be your lucky day, if you only knew.

<Prev in Thread] Current Thread [Next in Thread>