xfs
[Top] [All Lists]

Case of the dissapearing files!

To: linux-xfs@xxxxxxxxxxx
Subject: Case of the dissapearing files!
From: Ravi Wijayaratne <ravi_wija@xxxxxxxxx>
Date: Thu, 20 Jun 2002 13:25:50 -0700 (PDT)
Sender: owner-linux-xfs@xxxxxxxxxxx
Hi All,

I have an xfs root file system.

I increased the size of the inodes to 1024 by using
mkfs -i size=1024 option. After that I see some of the
newly created files in the "/" directory vanishing
when I reboot the system gracefully. However the newly
created  files in subdirectories are persistent
accross
reboots.

If I powercycle the system (ungraceful shutdown) the
newly created files in the "/" directory appears.

I ran xfs_db to examine the inode of the root
directory. I see that when I create a file (even non
empty) the files info (inode num, name etc) does not
appear in the inodes u.sfdir2.list[x].xxxx components.

My guess is that the file creation in the "/"
directory
gets registered in the xfs meta data logs but does not
update the incore inode and hence when the system is
shutdown does not write to the disk inodes. When the
system is abruptly shutdown xfs_repair reinstates the
files.

When I run xfs_repair -n on the root partition it
complains about unlinked inodes.

Furthermore  /proc/slabinfo tells me that the object
size is 436 bytes for the xfs_inode slab cache.

My questions are

(a). What is the maximum size for xfs_inode ? 1024 too
big ? 

(b). Why is the behavior different for "/" directory.
For instance "/tmp" or "/etc" works fine and I can
create and delete files in these directories.

Thanks
Ravi

=====
------------------------------
Ravi Wijayaratne

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com


<Prev in Thread] Current Thread [Next in Thread>