xfs
[Top] [All Lists]

Re: Strange behavior on the 2.4.18 XFS tree?

To: Keith Owens <kaos@xxxxxxx>
Subject: Re: Strange behavior on the 2.4.18 XFS tree?
From: Michael Sinz <msinz@xxxxxxxxx>
Date: Mon, 20 May 2002 08:34:03 -0400
Cc: linux-xfs@xxxxxxxxxxx
References: <22203.1021466116@xxxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.0rc1) Gecko/20020509
Keith Owens wrote:
On Wed, 15 May 2002 07:30:09 -0400, Michael Sinz <msinz@xxxxxxxxx> wrote:

I have only been able to see this behavior on my system running the
kernel from the 2.4 XFS CVS tree.  It is somewhat reproduceable.

The problem is that I started up a number of "rxvt" sessions and they
took well over a minute to start up.  During that time, the cpu
utilization was almost nil.  (Less than 1%)

There was a background find operation happening, and this seems to be
the key item.

When the problem occurs, does typing sync get everything running again?
I have been seeing an intermittent lock problem with XFS where
everything stops until some other disk activity kicks in and the lock
is released.

A build of 2.4.18-XFS from CVS on Friday night seems to not show the
problem.  At least not over the last 2+ days.

It could also be that I did not run into it either.  Just providing
some more information as it develops :-)

--
Michael Sinz ---- Worldgate Communications ---- msinz@xxxxxxxxx
A master's secrets are only as good as
        the master's ability to explain them to others.



<Prev in Thread] Current Thread [Next in Thread>