xfs
[Top] [All Lists]

Re: xfsrestore problems

To: John Kihonge <mkulima@xxxxxxx>
Subject: Re: xfsrestore problems
From: Charles Shannon Hendrix <shannon@xxxxxxxxxxxxx>
Date: Tue, 14 May 2002 23:48:09 -0400
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <3CE1835A.89040F77@sgi.com>
References: <20020511205125.GD4462@widomaker.com> <3CE1835A.89040F77@sgi.com>
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Mutt/1.3.23.2i
On Tue, May 14, 2002 at 04:36:26PM -0500, John Kihonge wrote:
> 
> Charles,
> 
> It is difficult at the moment to determine why xfsrestore is not working
> properly without getting more details from you. Here are afew quesions;
> 
> What is the xfsretore command line that you are using?

All of them... :)

Seriously, no combination of xfsrestore commands is special with regard
to restoring or not restoring files. I have tried incremental, sub-path
specification, and full restores. Incremental shows files but won't
restore them. xfsrestore -t shows files in the listing.

> What version of glibc are you using?

2.2.3 right now. Slackware came with an older version. I do not know
when I upgraded. However, I did a successful restore under 2.2.3 about a
month ago.

> Are there changes you have made to the kernel or libraries between the
> time the xfsrestore was working properly and the time you realized it
> wasnt? Are there any changes between the time you backed the files and
> now?

Yes. Starting last fall, I tracked XFS as it was updated, and made
kernel upgrades as the 2.4 series had problems and fixes were issued. I
have run kernel 2.4.9, 2.4.12, 2.4.16, and 2.4.18 with XFS current at
the time. I used whichever XFS was current for the kernel version at the
time I upgraded.

Unfortunately, I had to save space and remove my old kernels, so I
cannot give you an exact roadmap.

The other thing I track actively is the nVidia kernel drivers, patching
the kernel with each upgrade.

When I first started using XFS, I did a lot of testing to make sure it
worked, and have done several restores since then and they all worked.
I did a successful xfsrestore under kernel 2.4.16 and whatever XFS was
current with that release.

My best guess is that this problem is recent, but I could not prove that
for sure. The problem might simply not have affected my restores under
kernel 2.4.16, but I'm sure you know that.

I log all my backups. Unfortunately, I do not log my restores, though
I plan to start.

> What Linux are you running - SuSe, Red Hat, other?

Slackware 8.0 with utility upgrades as specified by the 2.4 series of
kernels.


-- 
UNIX/Perl/C/Pizza__________________________________shannon@xxxxxxxxxxxxx


<Prev in Thread] Current Thread [Next in Thread>