xfs
[Top] [All Lists]

Re: default acl inheritence bug

To: Ethan Benson <erbenson@xxxxxxxxxx>
Subject: Re: default acl inheritence bug
From: jtrostel@xxxxxxxxxxxxxx
Date: Mon, 29 Apr 2002 10:50:31 -0400 (EDT)
Cc: linux-xfs@xxxxxxxxxxx, Andreas Gruenbacher <ag@xxxxxxxxxxx>, Timothy Shimmin <tes@xxxxxxxxxxxxxxxxxxxxxxx>
In-reply-to: <20020428190221.G21791@xxxxxxxxxxxxxxx>
Organization: Quantum Corp. / NASD
Reply-to: jtrostel@xxxxxxxxxxxxxx
Sender: owner-linux-xfs@xxxxxxxxxxx
I do not see this behavior either (using code from CVS about 4/18)

[root@jtsdell xfs_part]# getfacl test_dir
# file: test_dir
# owner: root
# group: root
user::rwx
group::r-x
other::r-x
default:user::rwx
default:user:a100:r--
default:group::r-x
default:mask::r-x
default:other::r-x

[root@jtsdell xfs_part]# cd test_dir/
[root@jtsdell test_dir]# touch foo
[root@jtsdell test_dir]# getfacl foo
# file: foo
# owner: root
# group: root
user::rw-
user:a100:r--
group::r-x                  #effective:r--
mask::r--
other::r--

[root@jtsdell test_dir]# mkdir foo_dir
[root@jtsdell test_dir]# getfacl foo_dir
# file: foo_dir
# owner: root
# group: root
user::rwx
user:a100:r--
group::r-x
mask::r-x
other::r-x
default:user::rwx
default:user:a100:r--
default:group::r-x
default:mask::r-x
default:other::r-x


On 29-Apr-2002 Ethan Benson wrote:
> On Mon, Apr 29, 2002 at 12:35:05PM +1000, Timothy Shimmin wrote:
>> Hi Ethan,
>> 
>> Yeah your behaviour with the file gaining execute permission in the
>> user ACE definitely looks wrong _but_ I can NOT repeat it locally.
>> 
>>     tes@sagan /mnt/xfs0/testdir/test1> setfacl -dm u:tes:r-- .
>>     tes@sagan /mnt/xfs0/testdir/test1> getfacl .
>>     # file: .
>>     # owner: tes
>>     # group: tes
>>     user::rwx
>>     group::rwx
>>     other::r-x
>>     default:user::rwx
>>     default:user:tes:r--
>>     default:group::rwx
>>     default:mask::rwx
>>     default:other::r-x
>> 
>>     tes@sagan /mnt/xfs0/testdir/test1> touch foo
>>     tes@sagan /mnt/xfs0/testdir/test1> getfacl foo
>>     # file: foo
>>     # owner: tes
>>     # group: tes
>>     user::rw-
>>     user:tes:r--
>>     group::rwx                      #effective:rw-
>>     mask::rw-
>>     other::r--
>> 
>> You could try adding printk's in 
>> linux/fs/xfs/xfs_acl.c/xfs_acl_inherit() & xfs_acl_filter_mode() and 
>> see what is going wrong.
>> 
>> OOI, what is the output from running "check 051" in
>> the cmd/xfstests directory (i.e. the acl regression test) ?
>> (You need to look at cmd/xfstests/README about setting this stuff up;
>>  one needs to setup some variables to point to xfs filesystems etc...)
> 
> i assume you used current CVS XFS?  im on 2.4.18 split patches, so
> perhaps this is already fixed, ill check again when 2.4.19 is released.
> 
> -- 
> Ethan Benson
> http://www.alaska.net/~erbenson/

-- 
John M. Trostel
Senior Software Engineer
Quantum Corp. / NASD
jtrostel@xxxxxxxxxxxxxx


<Prev in Thread] Current Thread [Next in Thread>