xfs
[Top] [All Lists]

Can't get samba 2.2.3a to compile with ACL support (with logs)

To: samba@xxxxxxxxxxxxxxx
Subject: Can't get samba 2.2.3a to compile with ACL support (with logs)
From: Lars Weitze <cd@xxxxxxxxxxxx>
Date: Thu, 18 Apr 2002 19:06:27 +0200
Cc: linux-xfs@xxxxxxxxxxx
Organization: http://www.liquidsteel.net
Sender: owner-linux-xfs@xxxxxxxxxxx
Hi,

I've compiled everything: the whole acl package, the attr package the
xfs-progs etc. from the SGI CVS. I've installed all the devel packages.

But Samba 2.2.3a configure tells me that it can't find ACL support.

The line in the logs reads:
configure:12853: gcc -o conftest -O  -D_LARGEFILE64_SOURCE 
-D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE   conftest.c -lacl  -lcups
/usr/lib/libacl.so: undefined reference to `fgetxattr'
/usr/lib/libacl.so: undefined reference to `removexattr'
/usr/lib/libacl.so: undefined reference to `setxattr'
/usr/lib/libacl.so: undefined reference to `fsetxattr'
/usr/lib/libacl.so: undefined reference to `getxattr'


Logfile is attached.

Regards
Lars Weitze
-- 
    "Ihre Meinung ist mir zwar widerlich, aber ich werde mich
     dafuer totschlagen lassen, dass sie sie sagen duerfen."
                                                        Voltaire

PGP fingerprint:  4950 8576 778F DEDF 85D1  C04D 586F 2C45 E714 E13A

Attachment: config.log
Description: Binary data

<Prev in Thread] Current Thread [Next in Thread>