xfs
[Top] [All Lists]

Re: XFS installer and driver/update disks

To: Thor Lancelot Simon <tls@xxxxxxxxxxxx>
Subject: Re: XFS installer and driver/update disks
From: Simon Matter <simon.matter@xxxxxxxxxxxxxxxx>
Date: Fri, 12 Apr 2002 20:53:06 +0200
>received: from mobile.sauter-bc.com (unknown [10.1.6.21]) by basel1.sauter-bc.com (Postfix) with ESMTP id 6B6D757306; Fri, 12 Apr 2002 20:53:07 +0200 (CEST)
Cc: linux-xfs@xxxxxxxxxxx
References: <20020412133802.A26968@xxxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Thor Lancelot Simon schrieb:
> 
> I have a new system with an Adaptec I2O RAID controller.  I'd
> really like to use XFS on this system, but I'm having a terrible
> time getting it installed.
> 
> The RedHat 7.2 distribution doesn't ship with the Adaptec/DPT I2O
> driver.  Adaptec has a driver disk, but of course the kernel versions
> differ between standard RedHat 7.2 and SGI 7.2+XFS, so the driver
> doesn't match what anaconda looks for and doesn't work if loaded by
> hand (doesn't load, actually; missing symbols).  I tried downloading
> the Adaptec driver sources and the XFS-patched RedHat kernel sources
> but building a driver disk that actually works appears to be beyond
> my abilities; adaptec's driver sources are distributed as a patch
> against 2.4.6, so I have no idea how the 2.7-10 redhat kernel modules
> were built.  Later kernel versions have the dpti driver included in
> the Linus sources, but not what RedHat uses on their install disks.
> 
> There's also an "updates" disk distributed with the RedHat 7.2 driver
> disk; it includes a new "packages.py" but with no real knowledge of
> Python I can't really see the difference, nor tell if it will work right
> with the SGI anaconda.

You have exactly the same problem I had with two Servers. I solved it by
installing Linux Mandrake.

The real problem is that RedHat does not include XFS in their kernel.
They ship it with 1001 patches applied but no XFS. It's a real pain. I
have then tried Skipjack-beta1 in the hope, they included XFS. Nothing.
I decided to call this a bug and posted it on bugzilla.

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=62072

I'm asking list members not to flame on bugzilla. I guess it won't help.

-Simon

> 
> What's the right thing to do here?  If anyone cares to look at the
> RedHat/Adaptec solution for stock RedHat 7.2, it's at
> http://people.redhat.com/tcallawa/dpt/; driver source tarball is down
> at the bottom of the page.
> 
> I tried a stock RedHat install but ext3 leaves much to be desired.  I
> really want XFS on this box, but how?
> 
> Thor



<Prev in Thread] Current Thread [Next in Thread>