xfs
[Top] [All Lists]

Re: file coruption on power fail

To: Simon Matter <simon.matter@xxxxxxxxxxxxxxxx>
Subject: Re: file coruption on power fail
From: Mike Baptiste <mike@xxxxxxxxxxxxxxxx>
Date: Thu, 28 Mar 2002 19:20:17 -0500
Cc: Ivan Ivanov <ivandi@xxxxxxxxxxxxxxx>, linux-xfs@xxxxxxxxxxx
References: <Pine.LNX.4.44.0203251354250.8170-100000@xxxxxxxxxxxxxxxxxxxxx> <3CA3A9C8.9060705@xxxxxxxxxxxxxxxx> <3CA3B089.EEA70773@xxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020326
Well I thought about that - however, the updates were NOT XFree updates
- only gnome core.  So those files should not have been touched (OK
maybe read - but thats it)  And the files weren't zero'ed - they were gone.

Also, I had the same problem on my desktop at home which runs ext3.
Same config as my laptop (RH 7.2, 2.4.18, etc) but ext3 instead of xfs.
~ When gnome froze during the update (not X, it was Gnome - the mouse
would still respond) I powered down and when I turned it back on, the
file system repaired and X worked just fine.

Not conclusive by any stretch, but my desktop and laptop are very
similar - just one uses ext3 (the desktop) while the laptop uses xfs.

FWIW.

Mike

Simon Matter wrote:
| Mike Baptiste schrieb:
|
|>FWIW - I had the exact same problem.  I'm running 2.4.18-xfs, compiled
|>with gcc3.0.4 on RH 7.2  I was running red-carpet to update gnome and it
|>updated a LOT of core gnome packages.  Well, X froze solid (except for
|>the mouse)  ctrl-alt-backspace did nothing (2nd system this happened to
|>me).  Finally after waiting a good long while, I powered down.
|
|
| Are you sure it was not the gnome update which corrupted your libraries?
| That could explain why xfs_repair found nothing wrong. I'm quite sure
| this time it was not XFS. Too bad you didn't check the failed libs and
| look whether they contain "the zero's".
|
| Anyway, zero filled files after unclean shutdown is one of the weak
| points of XFS. As Steve mentioned, it was adressed with recent changes
| and I expect it has and will improve much.
|
| If you have a stable kernel and a good power supply with UPS, the risk
| of loosing anything on a XFS filesystem is _very_ low. On unstable
| kernels and power supplies, there is always a chance to loose some
| bit's.
|
| -Simon
|
|
|>When I restarted, I got a bunch of error msgs due to missing libraries
|>(X and kerberos)  X refused to start.
|>
|>I did an xfs_repair - no help.  Since I was on XFree 4.1.0, I grabbed
|>the 4.2.0 rpms and installed those from the command line along with the
|>kerberos RPMs using the --force option.
|>
|>After that, everything worked fine.  Nothing else got corrupted - only
|>the X libraries (well that I've found so far - but I use this system
|>heavily and everything seems to be happy)
|>
|>Wish I had more info - but this was at work so I just got it working
|>again with the rpm install.
|>
|>Mike
|>
|>Ivan Ivanov wrote:
|>| Are there any chances for solving this problem.
|>|
|>| I have read all the faq and the XFS white paper.
|>| I have tried allmost all XFS patches from oss.sgi.com for various
kernels
|>| and know that XFS logs only metadata updates.
|>| It is fast, has EA and ACL but when the system crashes for any
reason most
|>| of the open files ( including opened ro ) are lost - for example
|>| XF86Config.
|>|
|>| Regards
|>| Ivan
|>|
|
|



<Prev in Thread] Current Thread [Next in Thread>