xfs
[Top] [All Lists]

Linux 2.4.18 freeze running dbench 1.3

To: <linux-xfs@xxxxxxxxxxx>
Subject: Linux 2.4.18 freeze running dbench 1.3
From: Christian Røsnes <christian@xxxxxxxxx>
Date: Sat, 2 Mar 2002 15:48:30 +0100
Importance: Normal
Sender: owner-linux-xfs@xxxxxxxxxxx
Hello

Everytime I run dbench 1.3 on a linux kernel 2.4.18 from the XFS cvs
checkout,
I'm experiencing complete lockups on Compaq Proliant DL380 G2 servers.
        * Dual cpu 1266 Mhz,
        * SmartArray Raid controller
        * 2 x 36 GB HD in Raid 1
        * 1256 MB RAM
        * eepro100 NIC

(I've installed RedHat 7.2 with the SGI 1.0.2a installer.)

Dbench works fine when running it with the 2.4.9-13SGI_XFS_1.0.2smp kernel
from the SGI installer.

The freeze happens evertime when I start dbench 1.3 with the 2.4.18 kernel:
(I'm running it on my /usr partition which is xfs formatted and mounted)

Eg:
./dbench 10
Starting 10 clients
<system freezes>

The system then becomes unresponsive, and reseting the machine
is the only way to get it back on its feet.
I've tested this on two different DL380 G2s, and it locks up on both.

Is anyone else seeing this ?

Is there any way I can debug this ?
When the system freezes, there are no more entries in /var/log/messages.
There are no Oopses.

I've included my kernel config file (gzipped) and the message output found
in
/var/log/messages (also gzipped).

Any help appreciated. Thank you.

(I do not have physical access to the machines at the moment,
but will on Monday)

Christian

-------------------------- CHECKOUT INFO -------------------------------

I've tried checkouts Thursday,Friday and today - all freeze up
when running 2.4.18 and dbench 1.3:

#!/bin/sh
#
export CVSROOT=':pserver:cvs@xxxxxxxxxxx:/cvs'
cvs login
# FULL CHECKOUT
cvs -z3 checkout linux-2.4-xfs


------------------------------ XFS INFO --------------------------------

Here's the xfs info from the /usr partition in run dbench on.

[root@dl01 xfs]# xfs_info /usr
meta-data=/usr                   isize=256    agcount=14, agsize=262144 blks
data     =                       bsize=4096   blocks=3584280, imaxpct=25
         =                       sunit=0      swidth=0 blks, unwritten=0
naming   =version 2              bsize=4096
log      =internal               bsize=4096   blocks=1200
realtime =none                   extsz=65536  blocks=0, rtextents=0


------------------------------ MOUNT INFO --------------------------------

I've tried to mount /usr with both default logbufs and logbsize values,
and also the parameters listed for /usr below  (logbufs=8,logbsize=32768).
There are dbench lockups in both cases.

[root@dl01 xfs]# mount
/dev/cciss/c0d0p6 on / type xfs (rw)
none on /proc type proc (rw)
/dev/cciss/c0d0p1 on /boot type ext2 (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/cciss/c0d0p7 on /home type xfs (rw,logbufs=8,logbsize=32768)
none on /dev/shm type tmpfs (rw)
/dev/cciss/c0d0p2 on /usr type xfs (rw,logbufs=8,logbsize=32768)
/dev/cciss/c0d0p3 on /var type xfs (rw,logbufs=8,logbsize=32768)

Attachment: messages.gz
Description: GNU Zip compressed data

Attachment: kernel_config_file.gz
Description: GNU Zip compressed data

<Prev in Thread] Current Thread [Next in Thread>