xfs
[Top] [All Lists]

RE: oops umounting full LVM snapshots

To: "'Eric Sandeen'" <sandeen@xxxxxxx>
Subject: RE: oops umounting full LVM snapshots
From: "Stephenson, Dale" <dstephenson@xxxxxxxxxxxxxx>
Date: Tue, 26 Feb 2002 10:48:35 -0800
Cc: "'linux-xfs@xxxxxxxxxxx'" <linux-xfs@xxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Eric Sandeen wrote:
> 
> Ok, I tried adding quota to the mix, and it still doesn't 
> fall down for
> me...  Do you guys have some other XFS changes in the mix?
> 
> -Eric
>
The only change to xfs in my build is the VFS lock patch and Danny Cox's
extended ACLs patch.  I've attached Danny's patch in case you want to look
at it, but I pulled it out and rebuilt my kernel without it--didn't fix the
problem.  I followed the same steps as you, and I'm still getting an I/O
error umounting the snapshot. 

The only difference remaining I can see from your test and my last test is
that I made my volume group from a single IDE drive partition, not two scsi
partitions.

At this point, the only patches I'm applying that are anywhere in the test
path are:

1) the LVM patch to upgrade to 1.0.3
2) the VFS lock patch
3) some miscellaneous IDE patches

I wouldn't expect the IDE patches to matter, since a full snapshot shouldn't
be letting any I/O through to the drive below.  Just in case, I'm building a
kernel now with just the LVM patch.

Dale

> # This works for me:
> # create logical volume
> 
> vgcreate volgroup /dev/sda2 /dev/sda3
> lvcreate -L 100M -n logicalvol volgroup
> 
> # mkfs and mount it:
> 
> umount /dev/volgroup/logicalvol
> mkfs.xfs -f /dev/volgroup/logicalvol
> mount -o quota /dev/volgroup/logicalvol /mnt/lvm/logicalvol
> 
> # Make a couple snapshots and mount them:
> 
> lvcreate --size 16m --snapshot --name snap1 /dev/volgroup/logicalvol
> lvcreate --size 16m --snapshot --name snap2 /dev/volgroup/logicalvol
> mount -o ro,nouuid,norecovery /dev/volgroup/snap1 /mnt/lvm/snap1
> mount -o ro,nouuid,norecovery /dev/volgroup/snap2 /mnt/lvm/snap2
> 
> # Overflow the snapshots:
> 
> cp -aR /usr/src/linux-2.4.9-13SGI_XFS_1.0.2/ /mnt/lvm/logicalvol
> 
> # Unmount the snapshots:
> 
> umount /mnt/lvm/snap1/
> umount /mnt/lvm/snap2/

Attachment: ext_acl_2.4.16.patch
Description: Binary data

<Prev in Thread] Current Thread [Next in Thread>