xfs
[Top] [All Lists]

Re: problems with 2.4.14 rpms instalation

To: Miguel Angel de Vega <mvega@xxxxxx>
Subject: Re: problems with 2.4.14 rpms instalation
From: Stephen Lord <lord@xxxxxxx>
Date: Fri, 18 Jan 2002 07:01:25 -0600
Cc: linux-xfs@xxxxxxxxxxx
References: <200201181136.g0IBa5M11461@xxxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120
Miguel Angel de Vega wrote:

Hi!

I've tried to update my 2.4.9-XFS kernel to 2.4.14-XFS. But when I make a
rpm -ihv kernel-2.4.14-SGI_XFS_1.0.2.i686.rpm

i don't get an initrd-xxxxx.img to be done. I tried with mkinitrd and I got a .img, so I edited my grub.conf to get it to use both 2.4.14 files (vmlinuz & .img). When I rebooted the computer I got this error:

Kernel Panic
No init found. Try passing init=option to kernel.

I'm almost sure that I made the initrd file badly, or something like that.
I did't get such problems with 2.4.9-XFS.

?Any suggestions?

Thanks

Any XFS filesystems involved in the boot process? Unless you have a special
version of grub that is not going to work. Also, if this is related to your LVM
striping performance, try using the cvs kernel and building your own,  these
rpms are now really out of date.

Steve




<Prev in Thread] Current Thread [Next in Thread>