xfs
[Top] [All Lists]

Re: file corruption during emacs build on XFS logical volume

To: Linux XFS <linux-xfs@xxxxxxxxxxx>
Subject: Re: file corruption during emacs build on XFS logical volume
From: Sean Neakums <sneakums@xxxxxxxx>
Date: Thu, 03 Jan 2002 00:20:33 +0000
In-reply-to: <6ulmfgpau5.fsf@xxxxxxxxxxxxx> (Sean Neakums's message of "Wed, 02 Jan 2002 23:55:14 +0000")
Mail-followup-to: Linux XFS <linux-xfs@xxxxxxxxxxx>
References: <6u4rm4r53e.fsf@xxxxxxxxxxxxx> <1009995505.14223.9.camel@xxxxxxxxxxxxxxxxxxxx> <6uy9jgpn2x.fsf@xxxxxxxxxxxxx> <6uu1u4pf48.fsf@xxxxxxxxxxxxx> <1010013019.1281.6.camel@xxxxxxxxxxxxxxxxxxxx> <6upu4spccv.fsf@xxxxxxxxxxxxx> <1010013997.1315.11.camel@xxxxxxxxxxxxxxxxxxxx> <6ulmfgpau5.fsf@xxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Gnus/5.090004 (Oort Gnus v0.04) Emacs/21.1 (i386-debian-linux-gnu)
begin  Sean Neakums quotation:

> begin  Steve Lord quotation:
>
>> I completed an emacs build - surprisingly quickly, but I want to try
>> a different version, I am building rpms here and there is something
>> wrong with the rpm package I have - or it is incompatible with my
>> machine.... the compile worked, but the rpm failed to build, but the
>> error seems more to do with the rpm package itself than a corrupted
>> file.
>>
>> Have to dash now, more tomorrow.
>
> I've just realised that my swap is divided between two partitions.
> I've taken one and created an XFS filesystem on it.  Building emacs
> now.

Weird, it failed the with the same errors I was getting using the XFS
LVM volume:

  make[2]: *** No rule to make target 
`/datacomp/emacs21-21.1/src/../lisp/register.elc', needed by `../etc/DOC'.  
Stop.
  make[2]: Leaving directory `/datacomp/emacs21-21.1/src'
  make[1]: *** [src] Error 2
  make[1]: Leaving directory `/datacomp/emacs21-21.1'
  make: *** [debian/stamp-build] Error 2

I've been unpacking the source fresh for each try.

What seems to be causing this build error is that the dumped emacs
binary is missing.  I scrolled back in the make output, and saw
messages indicating that the dump had been successfully done to the
files src/emacs-21.1 and src/emacs, and that src/temacs had been
deleted.  But when I look in src/, temacs is still there, and there is
no sign of emacs-21.1 and emacs, but temacs is still there.

This is jolly strange.  Could the very presence of LVM be affecting
XFS, even though the filesystem is on a simple partition?

-- 
 /////////////////  |                  | The spark of a pin
<sneakums@xxxxxxxx> |  (require 'gnu)  | dropping, falling feather-like.
 \\\\\\\\\\\\\\\\\  |                  | There is too much noise.


<Prev in Thread] Current Thread [Next in Thread>