xfs
[Top] [All Lists]

mkfs on large h/w RAID fails

To: linux-xfs@xxxxxxxxxxx
Subject: mkfs on large h/w RAID fails
From: "Dave Sill" <ds-linux-xfs@xxxxxxxxxxxxxxxxx>
Date: 28 Jan 2002 12:02:59 -0500
In-reply-to: <F341E03C8ED6D311805E00902761278C07EFA858@xfc04.fc.hp.com>
Mail-followup-to: linux-xfs@xxxxxxxxxxx
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Gnus/5.0808 (Gnus v5.8.8) XEmacs/21.4 (Academic Rigor)
I've got a terabyte RAID that I'm trying to set up as a single XFS
filesystem. mkfs fails with:

[root@malachite root]# mkfs.xfs -f /dev/sdb1
meta-data=/dev/sdb1              isize=256    agcount=224, agsize=1048576 blks
data     =                       bsize=4096   blocks=234870292, imaxpct=25
         =                       sunit=0      swidth=0 blks, unwritten=0
         =                       imaxbits=32    
naming   =version 2              bsize=4096  
log      =internal log           bsize=4096   blocks=28670
realtime =none                   extsz=65536  blocks=0, rtextents=0
mkfs.xfs: read failed: Input/output error
mkfs.xfs: data size check failed
mkfs.xfs: mount initialization failed
[root@malachite root]# 

I had no problems mkfs'ing it as e2fs, e3fs, and reiserfs.

I'm running under the 1.02a installer on an Athlon:

[root@malachite root]# uname -a
Linux malachite 2.4.9-13SGI_XFS_1.0.2 #1 Thu Nov 15 14:28:44 CST 2001 i686 
unknown
[root@malachite root]# 

I installed the xfs programs from the RPM:

  xfsprogs-1.3.13-0.i386.rpm

Any ideas?

-Dave


<Prev in Thread] Current Thread [Next in Thread>