[Top] [All Lists]

Re: file corruption during emacs build on XFS logical volume

To: Linux XFS <linux-xfs@xxxxxxxxxxx>
Subject: Re: file corruption during emacs build on XFS logical volume
From: Sean Neakums <sneakums@xxxxxxxx>
Date: Thu, 03 Jan 2002 19:16:02 +0000
In-reply-to: <1010076426.12080.86.camel@jen.americas.sgi.com> (Steve Lord's message of "03 Jan 2002 10:47:06 -0600")
Mail-followup-to: Linux XFS <linux-xfs@xxxxxxxxxxx>
References: <6u4rm4r53e.fsf@zork.zork.net> <1009995505.14223.9.camel@jen.americas.sgi.com> <6uy9jgpn2x.fsf@zork.zork.net> <6uu1u4pf48.fsf@zork.zork.net> <1010013019.1281.6.camel@jen.americas.sgi.com> <6upu4spccv.fsf@zork.zork.net> <1010013997.1315.11.camel@jen.americas.sgi.com> <6ulmfgpau5.fsf@zork.zork.net> <6uheq4p9ny.fsf@zork.zork.net> <3C33AF81.AC235AD0@idcomm.com> <6ubsgbq013.fsf@zork.zork.net> <1010069377.23328.15.camel@jen.americas.sgi.com> <1010072382.23328.38.camel@jen.americas.sgi.com> <6u3d1npgx9.fsf@zork.zork.net> <1010075404.12080.79.camel@jen.americas.sgi.com> <1010076426.12080.86.camel@jen.americas.sgi.com>
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Gnus/5.090004 (Oort Gnus v0.04) Emacs/21.1 (i386-debian-linux-gnu)
begin  Steve Lord quotation:

> On Thu, 2002-01-03 at 10:30, Steve Lord wrote:
>> On Thu, 2002-01-03 at 09:56, Sean Neakums wrote:
>> > begin  Steve Lord quotation:
>> > 
>> > > Following up to myself, dropping the system memory to 128M seems to
>> > > have triggered the problem here, so yes there does seem to be an
>> > > XFS bug here.
>> > 
>> > Excellent.  I was beginning to think that it was something
>> > specific to my setup.
>> It gets even better, the other difference was that emacs was
>> already installed on the box were it worked, if I remove emacs it
>> fails to find it and fails in the same manner. So scratch memory
>> size as being the trigger here.

The box I was building on had emacs installed, showed consistent build
failure on XFS and consistent build success on ext2.  However...

> However, a build of emacs on a box running ext3 filesystems and no
> emacs installed fails with exactly the same error. So it would
> appear to not be XFS related at all, and more of an emacs build
> issue.
> Can you check out a build on another fs on a box which does not have
> emacs installed already? You could just rename your emacs binary
> rather than deinstall.

...I am building now on an ext2 volume, emacs removed.

(The build just passed the dump stage; src/emacs-21.1 is there and
src/temacs is not, as the make output indicates should be the case.)

Is there any chance that the mmap issue that Colin mentioned could be
cropping up on XFS, too?  Since the emacs21 build has worked for me on
2.4.14-pre7 on an XFS volume, perhaps there were changes introduced or
a fix accidentally reversed during a merge with the Linus tree tha
might trigger this.

 /////////////////  |                  | The spark of a pin
<sneakums@xxxxxxxx> |  (require 'gnu)  | dropping, falling feather-like.
 \\\\\\\\\\\\\\\\\  |                  | There is too much noise.

<Prev in Thread] Current Thread [Next in Thread>