xfs
[Top] [All Lists]

Re: Bug with 2.4.13?

To: GCS <gcs@xxxxxx>
Subject: Re: Bug with 2.4.13?
From: Steve Lord <lord@xxxxxxx>
Date: Fri, 26 Oct 2001 07:01:54 -0500
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: Message from GCS <gcs@xxxxxx> of "Fri, 26 Oct 2001 09:10:20 +0200." <20011026091020.B13113@xxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Hmm, please make sure you got the last change I checked into the tree 
yesterday, do one more cvs update and see if you get a new xfs_super.c
let me know what happens either way.

Steve

> Hi!
> 
>  I am using XFS with kernel 2.4.13. Yesterday I realised that I can not save
> anything to my /home, which is on XFS. Even touch /home/test as root said
> input/output error. umount went ok, and as I know fsck.xfs does nothing,
> I tried to mount it again. I got a lot of strange messages, like bad/invalid
> (?) version 0x7345435...
>  After reboot the mount crashes, and if I try it again, then it stucks in
> a D state. My distribution is Debian Woody. Here is a short report of the
> crash:
> Null pointer dereference at virtual address 0000152
> Eip: c01a30c7 (it points to pagebuf_unlock)
> Oops: 000
> Call trace: xlog_recover_process_iunlinks+328/644
>           xlog_recover_finish+53/144
>           xfs_log_mount_finish+31/48
>           xfs_mountfs+3070/3316
>           xfs_readsb+216/240
> 
> Code: 66 83 bb 6a 01 00 00 00 75 10 80 a3 50 01 00 00 f7 53 e8 7a
> 
> What should I do? Any help is appreciated.
> GCS



<Prev in Thread] Current Thread [Next in Thread>