xfs
[Top] [All Lists]

[BUG]XFS at CONFIG_SCSI_MULTI_LUN

To: linux-xfs@xxxxxxxxxxx
Subject: [BUG]XFS at CONFIG_SCSI_MULTI_LUN
From: Fang Han <dfbb@xxxxxxxxxxxx>
Date: Thu, 18 Oct 2001 17:32:11 +0800
Mail-followup-to: linux-xfs@xxxxxxxxxxx
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Mutt/1.2.5i
Hi, I find an very strange bug, And it is reproduce-able.

I have an machine with Adaptec 7899p card, And two scsi harddisk on one
scsi ID. It means I need use CONFIG_SCSI_MULTI_LUN options on
kernel. My kernel is SGI_XFS_1.0.1, I just enable the options, And
recompile it using RedHat 7.1 default gcc-2.9.6-85. 

My scsi harddisk shows to be sda sdb

When I run this script:
mkfs.xfs /dev/sdb1
time mount -t xfs /dev/sdb1 /mnt

I got this output 

real    0m9.340s
user    0m0.000s
sys     0m0.000s

The mount speed is real slow.
Using ext2xfs

mkfs /dev/sdb1
time mount /dev/sdb1  /mnt
output is :

real    0m0.392s
user    0m0.000s
sys     0m0.000s

Using resiserfs also very fast.

lvol1 can be from 500M - 10 G , And the result is same.

In the same time I run 

mkfs.xfs /dev/sda5
time mount -t xfs /dev/sda5 /mnt

result is:

real    0m0.523s
user    0m0.000s
sys     0m0.000s

sda5 size is same with sdb1

So the question is very clear, mount an XFS on the MULTI_LUN scsi
device is very slow. Who know the reason?

Dan



<Prev in Thread] Current Thread [Next in Thread>