xfs
[Top] [All Lists]

Re: XFS & the RedHat Installer

To: Bob Perper <bperper@xxxxxxxxxxxxxxxxx>
Subject: Re: XFS & the RedHat Installer
From: Joshua Baker-LePain <jlb17@xxxxxxxx>
Date: Wed, 19 Sep 2001 12:41:21 -0400 (EDT)
Cc: <linux-xfs@xxxxxxxxxxx>
In-reply-to: <5.1.0.14.2.20010919121845.00a8cec0@xxxxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
On Wed, 19 Sep 2001 at 12:29pm, Bob Perper wrote

> Hi,
>     My name is Bob Perper and I'm a developer of the backup product
> UPSTREAM.  When I used the "XFS for Red Hat Linux 7.1 Installer" to upgrade
> my RedHat 7.0 system to 7.1, it all worked well.  However, when I tried:
>       mkfs -t xfs /dev/hdb1
>     It reported the error:
>       mkfs.xfs: No such file or directory.

Do you have the xfsprogs RPM installed?

>     There's also no fsck.xfs in /sbin.

Same RPM, although keep in mind that the function of fsck.xfs (as the
rather droll man page points out) is to "do nothing, successfully".

>     However, the xfs daemon is running.

That's Something Completely Different -- the X font server.

>     I've been somewhat afraid to try to install any RPM's since it seems to
> be partially installed now.  Where should I go from here?

I've never used the installer, but it looks like it missed some stuff.
First, make sure that you are running an XFS kernel ('uname -a').  Then
make sure that you have the userland stuff installed -- at least xfsprogs
and xfsprogs-devel.

Then have another go at it.

-- 
Joshua Baker-LePain
Department of Biomedical Engineering
Duke University


<Prev in Thread] Current Thread [Next in Thread>