xfs
[Top] [All Lists]

Re: xfs on notebooks (noflushd etc.)

To: lord@xxxxxxx (Steve Lord)
Subject: Re: xfs on notebooks (noflushd etc.)
From: Sidik Isani <isani@xxxxxxxxxxxxxxx>
Date: Mon, 16 Jul 2001 22:03:21 -1000 (HST)
Cc: tgr@xxxxxxxxxxx (thomas graichen), linux-xfs@xxxxxxxxxxx
In-reply-to: <200107161415.f6GEFN401346@xxxxxxxxxxxxxxxxxxxx> from "Steve Lord" at Jul 16, 2001 09:15:23 AM
Sender: owner-linux-xfs@xxxxxxxxxxx
<Steve Lord wrote:>
|
|> just out of curiousity: how does xfs interact with things like
|> noflushd which reduce the disk flushing for more effective ide
|> poweroff possibilities ... is the flushing below the fs layer
|> so that it should all work transparently or may it result in
|> problems with xfs (or journaling fs in general)?
|> 
|> a lot of thanks in advance
|
|I have never tried noflushd, I see the FAQ says that it does not help with
|reiserfs because it bypasses normal delayed write mechanisms, xfs does the
|same type of thing, so there may be similar problems. Someone will have
|to try it and report back. 

  I tried it a while back, but couldn't convince myself that it really
  helped much, or was safe for XFS.  I also managed to get the disk to
  spin down _without_ noflushd, but there are a lot of things you need
  to check:

   - /tmp and /var are ramfs, and /dev is devfs on my system.
   - I "jumped through the hoops" Steve mentioned to get root mounted
     with noatime.  Without this, it's hopeless to get the disk to spin down.
   - Check for loop-devices if you're still getting disk spin-up.
   - I'm using XEmacs with auto-save turned off.
   - I 'ls -l' and 'cat' a bunch of files > /dev/null on bootup to be
     sure all basic libraries and programs start out completely cached.
   - ~/.netscape/history.dat needs to be a symlink to a file on ramdisk
     if you intend to leave netscrape running.
   - The list goes on (but gets further off-topic for XFS.)

  It works with 2.4.6, but somehow the way I'm booting 2.4.5 I was
  getting disk spin-up again.  It's a pain, basically.

  By the way, I solved my memory stats mystery.  I found some info on
  the kernel list about /proc/slabinfo which indicated that the memory
  listed here is not included in caches/buffers or any other specific
  entry in /proc/meminfo.  After adding up all the memory in
  /proc/slabinfo (which is a mess) and subtracting it from "used" memory,
  "used" memory is back to just process memory.

Be seeing you,

- Sidik

P.S.: I glommed the adjacent partition onto my XFS root partition
  the other day with fdisk and ran "xfs_growfs /".  Pretty easy.
  Cool stuff!  Thanks again.


<Prev in Thread] Current Thread [Next in Thread>