xfs
[Top] [All Lists]

Re: 2.4.7-pre8-xfs breaks VMWare

To: Linux XFS Mailing List <linux-xfs@xxxxxxxxxxx>
Subject: Re: 2.4.7-pre8-xfs breaks VMWare
From: "Bernhard R. Erdmann" <be@xxxxxxxxxxx>
Date: Sun, 22 Jul 2001 10:16:45 +0200
References: <3B5743C9.49891146@berdmann.de>
Sender: owner-linux-xfs@xxxxxxxxxxx
Path:
news.t-online.com!newsmm00.sul.t-online.com!newsfeed01.sul.t-online.de!t-online.de!newsfeed.online.be!news-hog.berkeley.edu!ucberkeley!nntp-relay.ihug.net!newsfeeds.ihug.co.nz!ihug.co.nz!news.vmware.com!not-for-mail
Message-ID: <9jc1nm$oe$1@xxxxxxxxxxxxxxxxx>
From: Carl Livitt <carllivitt@xxxxxxxxxxxxxxxxxxxxxxxx>
Newsgroups: vmware.for-linux.configuration
Subject: Re: vmware 2.0.4 broken with linux 2.4.7
Date: Sat, 21 Jul 2001 14:56:02 +0100
References: <9jbl2k$pq1$1@xxxxxxxxxxxxxxxxx>
Lines: 39
Organization: Organised? Me?
NNTP-Posting-Host: host213-122-181-34.btinternet.com
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7Bit
User-Agent: KNode/0.4
Xref: ente.berdmann.de vmware.for-linux.configuration:509

Bryan wrote:

> just upgraded to latest 2.4 series (2.4.7) and this is the first time
> I've seen vmware-config.pl fail:
> 

Same here. The Google groups has a link to a patch which addresses this 
issue. I've just installed it and whilst it gives compilation warnings,
the 
modules build and install OK.

I'm now happily running VMWare 2.0.4 under Linux 2.4.7. So, to make this 
work first download the patch:

        ftp://platan.vc.cvut.cz/pub/vmware/vmmon-for-2.4.7-only.tar.gz

Then copy it to the '/usr/local/lib/vmware/modules/source' directory.
Next, 
run:
        cd /usr/local/lib/vmware/modules/source 
        gunzip vmmon-for-2.4.7-only.tar.gz

After that, make a backup of the existing 'vmmon.tar' file and copy the
new 
one into its place: 

        cp vmmon.tar vmmon.tar.backup
        mv vmmon-for-2.4.7-only.tar vmmon.tar

Finally, run:

        vmware-config.pl

to set things up. That should give you a working VMWare installation
again.

Regards,

Carl.
-- 

Free Dmitri!
http://www.boycottadobe.com



Path:
news.t-online.com!newsmm00.sul.t-online.com!newsfeed00.sul.t-online.de!t-online.de!nntp-relay.ihug.net!newsfeeds.ihug.co.nz!ihug.co.nz!news.vmware.com!not-for-mail
Message-ID: <9jc37m$148$3@xxxxxxxxxxxxxxxxx>
From: Carl Livitt <carllivitt@xxxxxxxxxxxxxxxxxxxxxxxx>
Newsgroups: vmware.for-linux.configuration
Subject: Re: vmware 2.0.4 broken with linux 2.4.7
Date: Sat, 21 Jul 2001 15:22:19 +0100
References: <9jbl2k$pq1$1@xxxxxxxxxxxxxxxxx>
<9jc1nm$oe$1@xxxxxxxxxxxxxxxxx>
Lines: 22
Organization: Organised? Me?
NNTP-Posting-Host: host213-122-181-34.btinternet.com
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7Bit
User-Agent: KNode/0.4
Xref: ente.berdmann.de vmware.for-linux.configuration:510

Carl Livitt wrote:

In my previous post, part of the fix consisted of:

>         cp vmmon.tar vmmon.tar.backup
>         mv vmmon-for-2.4.7-only.tar vmmon.tar

Which is incorrect. It _should_ read:

>         mv vmmon.tar vmmon.tar.backup
>         mv vmmon-for-2.4.7-only.tar vmmon.tar

Sorry for any confusion. In fact, I typoed an earlier correction to this 
(ctrl-enter instead of enter) and sent an incomplete message to the
list. I 
cancelled it, but it still seems to be present so please ignore it.... I 
must need more caffeine!

Carl.
-- 

Free Dmitri!
http://www.boycottadobe.com


<Prev in Thread] Current Thread [Next in Thread>