xfs
[Top] [All Lists]

XFS at all? AND XFS and gcc ?!

To: linux-xfs@xxxxxxxxxxx
Subject: XFS at all? AND XFS and gcc ?!
From: Knuth Posern <posern@xxxxxxxxxxxxxxxxxxxxxxxxx>
Date: Sun, 17 Jun 2001 21:25:22 +0200 (MET DST)
Cc: seth.mos@xxxxxxxxx
Sender: owner-linux-xfs@xxxxxxxxxxx
Hi.

I would like to build a Software RAID-5. I don't have a
backup of my data (because it is too much data and backup-solutions are
too expansive for a student). That's why I want to use a Software-RAID-5
with redundancy.

But what FS to use?

Thats the point where XFS comes to play. Ext2 would be too slow with
fsck.ext2! - That's why it has to be a Journaling Filesystem.

I know you said: You don't recommend to use XFS in
productivity-environments.

But would you recommend me to NOT use XFS for my RAID-5, because with a
little bug all my data could be lost?!?!?! - Or are there versions which
are stable enough. If XFS is not PERFECT at the moment and needs debugging
would be o.k. for me and I would try to help you improving it. But it must
be at least a bit SAVE against (complete) DATA-LOSS...

---

I tried to build a 2.4.3-XFS kernel (but failed with the gcc - see
below). How UNsafe is 2.4.3-XFS against 2.4.2-XFS? And when will there be
an update which supports 2.4.4 or 2.4.5?

---

O.k. you wrote in your FAQ: about gcc 2.95: Hmmm there may be
problems ... but under Debian... and... ?!?!

So what? - Is it possible to use the gcc 3.0 or gcc 2.96 or do I have to
use the old 2.91.66 at the moment? And is there a x in 2.95.x which is
safe to use with the XFS-kernel?

And how long will it take till it is save to use the newer 2.95.x or 2.96
gcc-version?!

I tried to get the 2.91.66 C and C++ compiler installed on my system. But
it failed. And I don't know exactly why...

We tried to build egcs-1.1.2 C and C++ on TWO different systems:

        A) SuSE 7.2 with 
                kernel 2.4.4
                gcc-2.95.3-52
                gnu-libc6-2.2.2-38
                gnu-libc-devel-2.2.2-38

        B) Debian unstable with
                kernel 2.2.17
                gcc-2.95.4-1
                gnu-libc6-2.2.3-6
                gnu-libc6-devel-2.2.3-6

We downloaded:
        egcs-core-1.1.2.tar.bz2
        egcs-g++-1.1.2.tar.bz2

Extracted it, mkdir <objdir>, cd <objdir>, <egcs-1.1.2-srcdir>/configure.
This built a Makefile for the target-system: i586-pc-linux-gnu.

"make bootstrap" on bouth machines A and B in brought the following 
error-messages:

make[2]: Leaving directory
`/usr/src/prg/gcc/egcs-1.1.2_objdir/i586-pc-linux-gnumake[2]: Entering
directory `/usr/src/prg/gcc/egcs-1.1.2_objdir/i586-pc-linux-gntest 
x"no" != xyes || \
  /usr/src/prg/gcc/egcs-1.1.2_objdir/gcc/xgcc
-B/usr/src/prg/gcc/egcs-1.1.2_objd/usr/src/prg/gcc/egcs-1.1.2_objdir/gcc/xgcc
-B/usr/src/prg/gcc/egcs-1.1.2
_objdir/usr/src/prg/gcc/egcs-1.1.2/libio/indstream.cc: In method `struct
streampos indi/usr/src/prg/gcc/egcs-1.1.2/libio/indstream.cc:82: `struct
streampos' used 
where/usr/src/prg/gcc/egcs-1.1.2/libio/indstream.cc:85: `struct streampos'
used where/usr/src/prg/gcc/egcs-1.1.2/libio/indstream.cc:87: `struct
streampos' used 
where/usr/src/prg/gcc/egcs-1.1.2/libio/indstream.cc:89: conversion from
`int' to non-/usr/src/prg/gcc/egcs-1.1.2/libio/indstream.cc: In method
`struct streampos 
indi/usr/src/prg/gcc/egcs-1.1.2/libio/indstream.cc:99: `struct streampos'
used where/usr/src/prg/gcc/egcs-1.1.2/libio/indstream.cc:102: `struct
streampos' used 
wher/usr/src/prg/gcc/egcs-1.1.2/libio/indstream.cc:104: `struct streampos'
used wher/usr/src/prg/gcc/egcs-1.1.2/libio/indstream.cc:106: conversion
from `int' to 
nonmake[2]: *** [indstream.o] Error 1
make[2]: Leaving directory
`/usr/src/prg/gcc/egcs-1.1.2_objdir/i586-pc-linux-gnumake[1]: ***
[all-target-libio] Error 2
make[1]: Leaving directory `/usr/src/prg/gcc/egcs-1.1.2_objdir'
_______________________________________________________________
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

But what went wrong ???


Help would be very apreciated!!


Greetings,

Knuth Posern.



<Prev in Thread] Current Thread [Next in Thread>