xfs
[Top] [All Lists]

Re: using xfsdump with 'file device'

To: Christoph Lukas <christoph.lukas@xxxxxxx>
Subject: Re: using xfsdump with 'file device'
From: Steve Lord <lord@xxxxxxx>
Date: Mon, 18 Jun 2001 10:25:01 -0500
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: Message from Christoph Lukas <christoph.lukas@xxxxxxx> of "Mon, 18 Jun 2001 16:30:32 +0200." <0106181630320C.01455@skera>
Sender: owner-linux-xfs@xxxxxxxxxxx
> Hi,
> 
> we would like to use xfsdump to backup one of our xfs filesystems onto 
> another hard disk. Therefore I tried:
> 
> xfsdump -l0 -F -f /mnt/backupfile /dev/sda3
> 
> Although we are running kernel 2.4.3 and glibc _with_ >2GB support (tried 
> with 'dd if=/dev/null of=/mnt/testfile' ) xfsdump exits after dumping 2GB 
> with:
> 
> xfsdump: creating dump session media file 0 (media 0, file 0)
> xfsdump: dumping ino map
> xfsdump: dumping directories
> xfsdump: dumping non-directory files
> File size limit exceeded


This is odd, I just created a 2621561952 byte dump file here. Where did you
get the xfsdump program from - an RPM we built, or did you compile it yourself?

There are current command rpms here:

ftp://oss.sgi.com/projects/xfs/download/cmd_rpms/

which should be identical to the version I just tested with.

Steve


> 
> is there any possibility to exceed this limit (compile time option?) or any 
> easy alternative to work with multiple 2GB files (like the ordinary dump 
> does)?
> 
> Thanks,
> Christoph



<Prev in Thread] Current Thread [Next in Thread>