xfs
[Top] [All Lists]

Re: mkinitrd, ramdisk failure?

To: "XFS: linux-xfs@xxxxxxxxxxx" <linux-xfs@xxxxxxxxxxx>
Subject: Re: mkinitrd, ramdisk failure?
From: "D. Stimits" <stimits@xxxxxxxxxx>
Date: Wed, 13 Jun 2001 22:16:36 -0600
References: <Pine.LNX.4.33.0106131222080.5609-100000@xxxxxxxxxxxxxxxxxxxxx> <3B26C626.24EC0F20@xxxxxxxxxx> <3B26CC5E.6050804@xxxxxxxxxx> <3B26D839.E6C58E3E@xxxxxxxxxx> <3B26DCBB.2289C8FC@xxxxxxxxxxxxxxxx> <3B26E3DF.1B22B76A@xxxxxxxxxx> <3B26EFD1.723327FA@xxxxxxxxxxx> <3B27E2B5.CB5E4CF6@xxxxxxxxxx> <3B281A78.5000809@xxxxxxxxxx> <3B281DE1.EE4AFC33@xxxxxxxxxx> <3B2822F8.4010608@xxxxxxxxxx> <3B283464.A3667572@xxxxxxxxxx> <3B2837BD.AE16A48C@xxxxxxxxxxx>
Reply-to: stimits@xxxxxxxxxx
Sender: owner-linux-xfs@xxxxxxxxxxx
Russell Cattelan wrote:
> 
> "D. Stimits" wrote:
> 
> > To summarize, things are still failing. When I use modules for scsi, it
> > is apparent that no ramdisk is being used at all. I have tried
> > variations of using original mkinitrd, as well as mkinitrd.xfs. I
> > definitely have a ramdisk that contains the required modules, it just
> > ignores it. Here is the most recent mkinitrd command:
> > mkinitrd \
> >  -v \
> >  -f \
> >  --preload pagebuf \
> >  --preload xfs_support \
> >  --preload xfs \
> >  --with=scsi_mod \
> >  --with=sd_mod \
> >  --with=aic7xxx \
> >  /boot/ir-2.4.6-p1-xfs-3.img \
> >  2.4.6-pre1-xfs-3
> 
> I shouldn't make a difference but I would load the scsi drivers first.

I tried that variation, didn't work. I know from Walt's post though that
the preload above works for at least one person, so I posted this one.

> 
> >
> > boot=/dev/sda
> > map=/boot/map
> > install=/boot/boot.b
> > prompt
> > timeout=50
> > message=/boot/message
> > linear
> > vga=0x030c
> > default=2.4.6-p1-xfs-2
> > backup=boot.backup.when-2.4.6-pre1-xfs-3
> >
> > # FAILS, uses modules.
> > image=/boot/vmlinuz-2.4.6-pre1-xfs-3
> >         label=2.4.6-p1-xfs-3
> >         initrd=/boot/ir-2.4.6-p1-xfs-3.img
> >         read-only
> >         root=/dev/sda6
> >         append="noapic ramdisk_size=16000"
> 
> Why are you booting noapic?

The Intel i840 chipset has broken IO-APIC. It causes a fatal false irq
vector 217 into oblivion. I have talked to Alan Cox about this, there is
nothing that can be done without Intel, and email to Intel is rejected
since I am not a manufacturer or developer of their boards. Note that on
i840 boards that do not have 64 bit pci slots, there is only one of
these broken IO-APIC's, but on those with 64 bit, two more are added
that are connected to the pci. This causes random fatal error on heavy
pci use. It is 100% reproducable by simple things such as rapidly
mounting and umounting a CD ROM. You'll also notice that Intel does not
sell any high end servers with their own i840 chipset, they use
ServerWorks. i840 is defective, there is no choice about running without
apic.

> 
> When the system boots do you see messages about the ram disk loading?
> about XFS or Pagebuf  messages? scsi controller messages?

No ram disk loading messages. I do not know why. No messages about any
of the scsi or XFS or pagebuf stuff at all. If they occur at the very
start, right after lilo decompresses the kernel, at the moment when the
video mode changes, there is a period of blanking, and I can't see that.
But this is only a short part at the start, and I see a lot more.

D. Stimits, stimits@xxxxxxxxxx

> 
> --
> Russell Cattelan
> cattelan@xxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>