xfs
[Top] [All Lists]

RE: XFS install from ISO fails utterly

To: Eric Sandeen <sandeen@xxxxxxx>
Subject: RE: XFS install from ISO fails utterly
From: "Venables, Michael" <Michael.Venables@xxxxxxxxxx>
Date: Tue, 8 May 2001 17:48:00 -0500
Cc: linux-xfs@xxxxxxxxxxx
Sender: owner-linux-xfs@xxxxxxxxxxx
the mount points were as follows:

        /               256MB   XFS
        /boot           64      ext2 (also tried as XFS)
        /var            512     XFS
        /tmp            512     XFS
        /usr            4GB     XFS
        /home           20GB    XFS

        swap            256MB


-----Original Message-----
From: Eric Sandeen [mailto:sandeen@xxxxxxx]
Sent: Tuesday, May 08, 2001 5:38 PM
To: Venables, Michael
Cc: linux-xfs@xxxxxxxxxxx
Subject: Re: XFS install from ISO fails utterly


Hi -

Somebody asked for the installer guy?  :)

"Venables, Michael" wrote:
> 
> I tried installing Red Hat 7.1+XFS on a bare Compaq server, and when it
was
> all over, I got nothing that functioned.
> 
> The machine:
>         ProLiant 6400 (4x PII Xeon 450 w. 2MB cache)
>         4GB RAM
>         SmartArray 3200 array controller (raid 5)
>         Voodoo 5
> 
> The install process went smoothly, but there were numerous "no such file
or
> directory" errors on reboot. When it eventually hit a login prompt, none
of
> the filesystems which had been marked as XFS seemed to be present (/boot
was
> left as ext2).

The "no such file" stuff sounds like it _might_ be another devfs thing,
but I'd suspect the raid controller, see below.

How did you configure your system - what mount points were XFS?

> I've heard that there might be a block size issue with XFS supporting only
> 4k blocks and the Compaq Array controller supporting only 1k blocks. But I
> don't know if that's the issue here.

Also, Martin checked in some raid changes for BLKBSZSET and BLKBSZGET
ioctls - I think that mount will fail without this change?  

Martin says:

> The ... driver didn't support the ioctl for setting the software
> blocksize, so our last superblock ends up at a wrong offset causing
> mount to fail

Maybe Martin can comment if he's around...

-Eric

-- 
Eric Sandeen      XFS for Linux     http://oss.sgi.com/projects/xfs
sandeen@xxxxxxx   SGI, Inc.

<Prev in Thread] Current Thread [Next in Thread>