xfs
[Top] [All Lists]

strange fsr messages...

To: linux-xfs@xxxxxxxxxxx
Subject: strange fsr messages...
From: Ingo Paschke <ipaschke@xxxxxxxxxxxxxxx>
Date: Sat, 19 May 2001 21:03:25 +0200
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Mutt/1.2.5i
Hi!

I'm using RedHat 7.1/xfs on my desktop-box for several weeks now without any
problems (great work, btw), but today running "xfs_fsr" produced the
following kernel-messages (one for each xfs_fsr-pass):

fsr[1539]: xfs_fsr -m /etc/mtab -t 7200 -f /var/tmp/.fsrlast_xfs ... 
fsr[1540]: / startino=0 
kernel: kernel BUG at dcache.c:128!
kernel: invalid operand: 0000
kernel: CPU:    0
kernel: EIP:    0010:[<c0144178>]
kernel: EFLAGS: 00010282
kernel: eax: 0000001c   ebx: c21634c0   ecx: caebfb00   edx: fffffffe
kernel: esi: c21634c0   edi: ffffffe6   ebp: ca844000   esp: ca845bcc
kernel: ds: 0018   es: 0018   ss: 0018
kernel: Process xfs_fsr (pid: 1540, stackpage=ca845000)
kernel: Stack: c02a14e9 c02a1569 00000080 00000006 c21634c0 c01db477 c21634c0 
cfe9d680 
kernel:        bfffdb88 cfe84000 c01c586b cee01400 cfecd800 00000000 00000000 
00000002 
kernel:        bfffdbc8 00000018 00000000 00000000 83ed41a1 3d1c37f6 0000000e 
00000000 
kernel: Call Trace: [<c02a14e9>] [<c02a1569>] [<c01db477>] [<c01c586b>] 
[<c01dc5ad>]
                    [<c01c586b>] [<c01c586b>] 

After that, I rebooted into the install-CD-rescue mode and ran xfs_check which
didn't find any inconsistencies. Just to make sure, I also tried xfs_repair
-n, it didn't want to modify the filesystem.

But if I run fsr now, I get the following errors:

[root@xlan /root]# /usr/sbin/xfs_fsr 
xfs_fsr -m /etc/mtab -t 7200 -f /var/tmp/.fsrlast_xfs ...
/ startino=0
sync failed: ino=5303235: Invalid argument
sync failed: ino=5299225: Invalid argument
sync failed: ino=5299227: Invalid argument
sync failed: ino=5299226: Invalid argument
sync failed: ino=5299228: Invalid argument
sync failed: ino=5299231: Invalid argument
[... etc, about 100 messages]

This is on an Athlon-System with KT133 chipset (ASUS A7V), the XFS-filesystem
is on a disk connected to the Promise-controller. I installed RedHat 7.1 using
the XFS-1.0 install-CD, Kernel 2.4.2-XFS-1.0, compiled using egcs-2.91.66.

Has anyone else run into this problem yet?

If you need more info, feel free to ask.

Ciao,
Ingo.

<Prev in Thread] Current Thread [Next in Thread>