xfs
[Top] [All Lists]

Re: XFS & Kickstart installation

To: Eric Sandeen <sandeen@xxxxxxx>
Subject: Re: XFS & Kickstart installation
From: werner maes <werner.maes@xxxxxxxxxxxxxxxxx>
Date: Tue, 15 May 2001 11:46:56 +0200
Cc: linux-xfs@xxxxxxxxxxx
In-reply-to: <3B003E4A.FA627E01@sgi.com>
References: <3.0.6.32.20010514172946.007a3740@mail.cc.kuleuven.ac.be> <3.0.6.32.20010514183217.007ab100@mail.cc.kuleuven.ac.be>
Sender: owner-linux-xfs@xxxxxxxxxxx
At 15:21 14/05/2001 -0500, Eric Sandeen wrote:
>werner maes wrote:
>
>> I've done another test on a machine without hardware RAID (my first tests
>> were done on a machine
>> with a hardware RAID controller). I get a similar error: "Error mounting
>> device sda1 as /: No such
>> device. This most likely means that the partition has not been formatted."
>
>Not sure what's going on here, I tried a kickstart install on scsi
>drives (disabled the IDE controller for the HD, the CDROM was still
>enabled) and it worked just fine.  I tried a combination of ext2 and xfs
>filesystems, that worked too.  I don't have any RAID device to test it
>on.

Did you have your partitions already created with XFS? Or did you use a
"clean" disk?
Could you try to add "clearpart --all" to your configuration?
I've tried your ks.cfg but I still get the same error. I get the messages:
"Formatting
/, formatting /usr, formatting /home, ... but these commands don't take
much time. Therefore
I presume that the formatting has not been done correctly.

Below is my ks.cfg file which works fine with RH 7.1 but not with SGI
installer.
I did not add '--fs xfs' because XFS is the default.

auth --useshadow --enablemd5
clearpart --all
install
cdrom
keyboard us
lang en_US
lilo --location mbr
mouse genericps/2
network --bootproto dhcp 
part /tmp --size 500 
part /var --size 500 
part / --size 800 
part swap --size 128 
part /usr --size 1000 
part /home --size 500 --grow 
reboot
rootpw testtest 
timezone Europe/Brussels
%packages
@ Server



<Prev in Thread] Current Thread [Next in Thread>