[Top] [All Lists]

Re: XFS performance issue solved

To: <linux-xfs@xxxxxxxxxxx>
Subject: Re: XFS performance issue solved
From: Austin Gonyou <austin@xxxxxxxxxxxxxxx>
Date: Mon, 14 May 2001 13:43:25 -0500 (CDT)
In-reply-to: <Pine.LNX.4.33.0105132315290.27971-100000@UberGeek.coremetrics.com>
Sender: owner-linux-xfs@xxxxxxxxxxx
As promised I got my kernel recompiled on my "work" machine. One thing
which seemed to impact performance were the Kernel Debug Symbols. Ok,
stupid mistake, big booboo. Next I went ahead and enabled the DMA support
on this kernel. It was in fact NOT turned on. I also enabled PIIXn support
and tuning. After doing that specific change, my system improved
performance immediately. Good news there. After that, I continued further,
using HDPARM and got a full 65-80% increase in throughput. I used the
following options:

hdparm -X66 -d1 -u1 -c3 -m16 /dev/hdx

All parameters work like a champ, and I can even use them on my cdrom as
well. Now, not only does the system work it's butt off, but I can finally
make ISO's from cd to the hdd with no real slowdown, not like it was
before, nearly unuseable.

The conclusion:
  The problem here is chipset dependant. The DMA settings seem to affect
the system either way depending on what chipset you use. At this point,
true INTEL chipsets seem to need it turned on to get really good
performance, while AMD chipsets could probably have it turned on, but seem
to perform better without it. I will recompile once again, at home, and
pass the hdparm params to my devices there and report back with specific
findings. Thanks for those of you whom offered information and got me
started in these directions.

Austin Gonyou
Systems Architect, CCNA
Coremetrics, Inc.
Phone: 512-796-9023
email: austin@xxxxxxxxxxxxxxx

On Sun, 13 May 2001, Austin Gonyou wrote:

> Some of you have been writing about slow access times to stuff like rpm
> database, slocate db, etc. I've found one major thing which caused my
> system to return to it's normal smoking self. I recently got a new
> Athlon-C 1.333Ghz machine. I was very proud, and expected only the best
> out of this machine. I use the full 1.0 installer for 7.1. After
> installation, I discovered the RPM db was corrupt, and the system
> basically thought almost no packages were installed, despite the fact it
> booted with no real issues. I immediately got the 2.4.4 XFS devel tree,
> and recompiled, cause I've found that the new tree is much better than the
> default install version. My preference. Going through the recompile I
> chose to use the Generic DMA selection. I even decided to choose my ALI
> chipset. After rebooting the system was slightly better, no more devfs or
> other non-essential overhead. But there was still some fundamental issue.
> Pine, slocate, rpm, all were not NEARLY fast enough. I recompiled again,
> this time with no generic DMA support or ALI support. My system now
> performs like a 1.333 Ghz should. It smokes! File create/delete, and r/w
> times are pretty darn good. In some respects better than they've ever
> been. I'm going to hit this same build on my work box, a 433 Celeron, and
> see what happens. That is the more problematic box overall, but I know
> I've got similar options, regarding DMA, selected as well. I'll post when
> I see success/failure on that front in the AM.

<Prev in Thread] Current Thread [Next in Thread>