xfs
[Top] [All Lists]

Re: [linux-xfs] Problems compiling 2.4.3-xfs

To: "Brian C. Huffman" <sheep@xxxxxxxxx>
Subject: Re: [linux-xfs] Problems compiling 2.4.3-xfs
From: Russell Cattelan <cattelan@xxxxxxxxxxx>
Date: Thu, 19 Apr 2001 13:27:47 -0400
Cc: linux-xfs@xxxxxxxxxxx
References: <Pine.LNX.4.21.0104191725170.17559-100000@xxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
"Brian C. Huffman" wrote:

> All,
>

Hmm I don't think the gcc -V egcs-2.91.66 line works on right RH systems.
Try editing the Makefile to use kgcc instead.


>
>         I have successfully installed the Redhat 7.1 w/ XFS and everything
> works fine (except for the ide-cd thing that's been mentioned before).
> However I would like to recompile (b/c some things that I need are missing
> in stock).  I went out to get the 2.4.3 and have not been able to get it
> to compile no matter what I do.  Here are my first set of errors:
>
> ld -m elf_i386 -Ttext 0x0 -s --oformat binary bbootsect.o -o bbootsect
> gcc -V egcs-2.91.66 -E -D__KERNEL__ -I/root/linux-2.4-xfs/linux/include
> -D__BIG_KERNEL__ -traditional -DSVGA_MODE=NORMAL_VGA  setup.S -o bsetup.s
> as -o bsetup.o bsetup.s
> bsetup.s: Assembler messages:
> bsetup.s:1306: Warning: indirect lcall without `*'
> bsetup.s:2113: Error: undefined symbol VIDEO_FIRST_V7 in operation
> bsetup.s:2138: Error: undefined symbol VIDEO_RECALC in operation
> bsetup.s:2141: Error: undefined symbol VIDEO_FIRST_RESOLUTION in operation
> bsetup.s:2144: Error: undefined symbol VIDEO_FIRST_SPECIAL in operation
> bsetup.s:2147: Error: undefined symbol VIDEO_FIRST_V7 in operation
> bsetup.s:2150: Error: undefined symbol VIDEO_FIRST_VESA in operation
> bsetup.s:2165: Error: undefined symbol VIDEO_FIRST_VESA in operation
> bsetup.s:2226: Error: undefined symbol VIDEO_FIRST_VESA in operation
> bsetup.s:2230: Error: undefined symbol VIDEO_FIRST_VESA in operation
> bsetup.s:2244: Error: undefined symbol VIDEO_FIRST_VESA in operation
> bsetup.s:2262: Error: undefined symbol VIDEO_RECALC in operation
> bsetup.s:2722: Error: undefined symbol VIDEO_FIRST_VESA in operation
> bsetup.s:2128: Error: Value of -3840 too large for field of 1 bytes at
> 3021
> bsetup.s:2188: Error: Value of -3840 too large for field of 1 bytes at
> 3111
> make[1]: *** [bsetup.o] Error 1
> make[1]: Leaving directory `/root/linux-2.4-xfs/linux/arch/i386/boot'
> make: *** [bzImage] Error 2
>
> then I did 'make mrproper', reconfiged (removing frame buffer support) and
> tried again.  Now I still get this!
>
> ld -m elf_i386 -Ttext 0x0 -s --oformat binary bbootsect.o -o bbootsect
> gcc -V egcs-2.91.66 -E -D__KERNEL__ -I/root/linux-2.4-xfs/linux/include
> -D__BIG_KERNEL__ -traditional -DSVGA_MODE=NORMAL_VGA  setup.S -o bsetup.s
> as -o bsetup.o bsetup.s
> bsetup.s: Assembler messages:
> bsetup.s:1280: Warning: indirect lcall without `*'
> ld -m elf_i386 -Ttext 0x0 -s --oformat binary -e begtext -o bsetup
> bsetup.o
> bsetup.o: In function `start_of_setup':
> bsetup.o(.text+0x43e): undefined reference to `SIG1'
> bsetup.o(.text+0x446): undefined reference to `SIG2'
> bsetup.o: In function `bad_sig':
> bsetup.o(.text+0x4c6): undefined reference to `SIG1'
> bsetup.o(.text+0x4ce): undefined reference to `SIG2'
> bsetup.o: In function `meme820':
> bsetup.o(.text+0x528): undefined reference to `E820MAP'
> bsetup.o: In function `jmpe820':
> bsetup.o(.text+0x532): undefined reference to `SMAP'
> bsetup.o(.text+0x544): undefined reference to `SMAP'
> bsetup.o: In function `good820':
> bsetup.o(.text+0x54e): undefined reference to `E820MAX'
> make[1]: *** [bsetup] Error 1
> make[1]: Leaving directory `/root/linux-2.4-xfs/linux/arch/i386/boot'
> make: *** [bzImage] Error 2
>
> What can I do?
>
> Thanks in advance,
> Brian

--
Russell Cattelan
--
Digital Elves inc. -- Currently on loan to SGI
Linux XFS core developer.




<Prev in Thread] Current Thread [Next in Thread>