xfs
[Top] [All Lists]

Re: shutdown umount hangs

To: Steve Lord <lord@xxxxxxx>
Subject: Re: shutdown umount hangs
From: Utz Lehmann <leh@xxxxxxxxxx>
Date: Thu, 5 Apr 2001 16:51:44 +0200
Cc: cattelan@xxxxxxxxxxx, linux-xfs@xxxxxxxxxxx
In-reply-to: <200104051412.f35ECMU25857@xxxxxxxxxxxxxxxxxxxx>; from lord@xxxxxxx on Thu, Apr 05, 2001 at 09:12:22AM -0500
References: <leh@xxxxxxxxxx> <200104051412.f35ECMU25857@xxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
User-agent: Mutt/1.2.5i
Hi

I think it's a knfsd - xfs issue.

I just make test without starting knfsd and it works (with and without the
pb_patch). Sorry, i had forgotten to test this earlier .-(((
Even when i exported nothing it hangs. The knfsd is configured for nfs v2
and v3.

But I need to start /etc/init.d/nfsserver for locking. My mutt complained
that it can not lock my mailfolder which are nfs mounted.


ok, and now i will do this below.


utz


Steve Lord [lord@xxxxxxx] wrote:
> 
> OK, you made it a lot further through unmount than before, there are
> two disk I/O's left until you are unmounted from here, and you are
> waiting for one of them to complete - not sure why it is not completing
> yet - previously you were stuck at the start of unmount. Russell changed
> the code in a different direction than we had discussed, I need to go look 
> at what he did. If you have the kdbm_pg module in the kernel when this
> happens can you take the first argument of pagebuf_iowait and run the
> pb command on it? From the stack below that would be:
> 
> kdb> pb 0xcf724180
> 
> Thanks for trying this stuff out for us.
> 
> Steve

<Prev in Thread] Current Thread [Next in Thread>