xfs
[Top] [All Lists]

Re: XFS 2.4.3 patch

To: Ajay Shekhawat <ajay@xxxxxxxxxxxxxxxxx>
Subject: Re: XFS 2.4.3 patch
From: Russell Cattelan <cattelan@xxxxxxxxxxx>
Date: Sun, 01 Apr 2001 16:05:21 -0500
Cc: linux-xfs@xxxxxxxxxxx
References: <3AC6733F.3B62AC5E@xxxxxxxxxxx> <20010401145556.U16131@xxxxxxxxxxxxxxxxxxxxxxxx>
Sender: owner-linux-xfs@xxxxxxxxxxx
Ajay Shekhawat wrote:

> On Sat, Mar 31, 2001 at 06:15:59PM -0600, Russell Cattelan wrote:
> > A preliminary XFS patch for 2.4.3 has been placed on
> > oss.sgi.com/linux-xfs.sgi.com
> > ftp://linux-xfs.sgi.com/projects/xfs/download/patches/
> >
> > This has passed basic bonnie and dbench runs, but has
> > not been extensivly tested, but due to the limited number
> > of changes things should work just fine.
> >
> > The CVS tree will be updated in the next few days.
> >
> > -Russell
>
> I built the 2.4.3-XFS kernel on our test machine, and tried hammering on
> the machine via NFS. Unfortunately, after about 10 hours or so of work,
> I get an "oops". The messages are attached below. It _appears_ that the
> machine is running out of some resource.  The second 'oops' below occured
> when I tried to rlogin into the machine; it is caused by "tcsh" !
>

Off hand I really don't have any suggestions .
Best guess looking at this would be either a bad dcache entry or
like you said some resource is being exhausted.
I suppose looking at some stats in /proc might help. all though without
knowing what resource it running low, what to watch?

could you turn on kdb? so we can start looking at the problem with that?


>
> Any help in tracking this down would be appreciated.
>
> Ajay
>
>   ------------------------------------------------------------------------
>
>    ksymoops.txt.20Name: ksymoops.txt.20
>                   Type: Plain Text (text/plain)
>
>    ksymoops.txt.33Name: ksymoops.txt.33
>                   Type: Plain Text (text/plain)

--
Russell Cattelan
cattelan@xxxxxxxxxxx




<Prev in Thread] Current Thread [Next in Thread>