xfs
[Top] [All Lists]

Re: quota

To: Thomas Graichen <graichen@xxxxxxxxxxxxx>, thomas.graichen@xxxxxxxxxxxxxx, linux-xfs@xxxxxxxxxxx
Subject: Re: quota
From: "Nathan Scott" <nathans@xxxxxxxxxxxxxxxxxxxxxxxx>
Date: Fri, 2 Feb 2001 10:44:30 -0400
In-reply-to: Thomas Graichen <news-innominate.list.sgi.xfs@innominate.de> "quota" (Feb 1, 11:07pm)
References: <news2mail-95cq8e$6ce$1@mate.bln.innominate.de>
Sender: owner-linux-xfs@xxxxxxxxxxx
hi Thomas,

On Feb 1, 11:07pm, Thomas Graichen wrote:
> Subject: quota
> i am a bit confused about quota on XFS ... all started by getting
> messages like
> 
>   user enforcement is already disabled
> 

sounds like a logic error in quotaoff - I'll have a look,
thanks.

> etc. from the quotaoff -a in the normal redhat shutdown scripts - this
> brought me to look at the quota stuff - ok i tried to enable quota now
> but for me it does not work like described in the quotaon man-page
> (the XFS quota man page)
> 
>   rootfs -> quotaon -v / and reboot
> 

this is probably the one situation I haven't got round to
trying out yet ;) - quota on root are a special case in
XFS, so theres possibly a bug lurking in there.

> but after rebooting root did not have quota ... i also added

how did you check that?  (repquota -s?)

> ",usrquota" to the fstab entries for the non / partitions but some-
> how it did not work (but i have to check that in more detail - so

this should definately work, I run many filesystems in this
mode all the time.  in what way did it not work?

> maybe ignore this one for now) ... ok - but now the quotaon on
> bootup complains about "quotas have to be enabled on mount" ...

this is probably related to the root fs issue somehow
(probably a related error to above since quotaon==quotaoff).

> 
> ok - while trying all this i found out that somehow the grpquota
> stuff does not work at all for now (i think i remember something
> like grpquotas not working from the lists) - right?
> 

yes, thats right.

> so - before i try further - can anyone please say some words
> about the status of the quota stuff: is the quotaon/quotaoff
> output on bootup/shutdown normal for now (or am i doing something
> wrong)? what is the state of the grpquota stuff? and how one
> really enables quota on XFS filesystems? (my idea would be
> 
>   quotaon -v /
> 

in theory, yes.  i'll need to do some work to test out this
case though.

status of group quota is:  IRIX has a "projects" concept which
is similar to groups but used for accounting purposed rather
than security.  the IRIX version of XFS implements project
quota instead of group quota.  since Linux has no notion of
projects, I need to come up with a plan B (on my todo list)
and its not as simple as "just use gids instead of projids",
obviously.  this'll take awhile...

> for the rootfs + reboot and an
> 
>   ... defaults,usrquota
> 
> entry in the fstab for all the other XFS fs + reboot (or remount)
> - right or anything wrong on this idea?

no reboot is required for non-root filesystems.  unmount &
then mount is all thats required.  a remount would be nice
but I haven't had a chance to look into that mechanism yet.
switching quota on for / is really fiddly in IRIX (needs a
reboot), so this may be a much cleaner way for doing root
quota in Linux... I'll use that as my excuse for not testing
quota on / yet. ;-)

to date, I have just been concentrating on porting from IRIX
and getting the basic functionality in place.

> 
> a lot of thanks in advance
> 

no worries - thanks for the bug report.

cheers.

-- 
Nathan

<Prev in Thread] Current Thread [Next in Thread>
  • quota, Thomas Graichen
    • Re: quota, Thomas Graichen
    • Message not available
      • Re: quota, Nathan Scott <=